[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: enabling/disabling AltiVec in Firefox and derived browsers (ArcticFox)



Hi Luke,


Luke Kenneth Casson Leighton wrote:
>
> 1.5 and 1.9 never had SIMD / VMX / VSX so there shouldn't be a problem
> (for G5).
>
> which, coming back to the original question, i'm not seeing a reason
> why disabling altivec should not compile.
>
> unless, of course, there have been assumptions "#ifdef PPC64 equals
> POWER9 therefore VSX" which are unfortunately creeping in ever since
> EABI 2.0 came about?

actually the original point is even for PPC32, note just PPC64. The
configure check added by Adrian in Firefox checks if the compiler
accepts -maltivec and just enables it in the build.
However, this assumption is not correct and causes issues as explained
in my previous mail.

Riccardo


Reply to: