[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Please help: systemctl: error while loading shared libraries

Hi all!

I am a user of Debian PowerPC. For several months, I receive the following error:

systemctl: error while loading shared libraries: R_PPC_REL24 relocation at 0x004a8880 for symbol `gcry_control' out of range

My system:

Openwrt 15.05, LXC container

OS: Debian Linux 10.0 (within LXC container)

Architecture: powerpcspe

root@debian2:~# lscpu
Architecture:        ppc
CPU op-mode(s):      32-bit
Byte Order:          Big Endian
CPU(s):              2
On-line CPU(s) list: 0,1
Thread(s) per core:  1
Core(s) per socket:  1
Socket(s):           2
Model:               5.1 (pvr 8021 1051)
Model name:          e500v2
BogoMIPS:            150.00
L1d cache:           32K
L1i cache:           32K
L2 cache:            512K

I am not a developer, so solving the problem is beyond my skills. I do not know which library (used by systemctl) is causing the problem. I tried to google some solutions. It seems that some library has been incorectly compiled. See https://stackoverflow.com/questions/12862830/r-ppc-rel24-relocation-out-of-range

Thank you very much!


Dne 25.11.2018 v 21:42 John Paul Adrian Glaubitz napsal(a):

On 11/25/18 9:39 PM, Rick Thomas wrote:
Thanks, Adrian, for the clear explanation of this and the other problems.
FWIW, the issue with sane-backends should be resolved now. I fixed net-snmp.


I just re-tried this and I still get that linux-image-powerpc depends on linux-image-4.18.0-2-powerpc, which does not exist.  The version it’s trying to upgrade to is linux-image-powerpc 4.18+99 from sid.

However, linux-image-4.18.0-3-powerpc does exist.  Is there an updated version of linux-image-powerpc lurking somewhere that I need to get?
You need to wait for the src:linux-latest package to be updated:

The current on still depends on the older kernel. FWIW, you don't need linux-image-powerc,
it's just a meta-package. It just helps keeping the kernel up-to-date automatically
as it will always depend on the latest version of linux-image-$VERSION-powerpc

PS:  I manually installed linux-image-4.18.0-3-powerpc, and it seems to be working fine.  Presumably, once linux-image-powerpc gets updated to depend on “-3” I can safely do “aptitude markauto linux-image-4.18.0-3-powerpc” and all will be well?


Reply to: