[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-ports.org getting relatively unstable (hppa)

Hello Aurelien,

On 12/15/2013 09:03 PM, Aurelien Jarno wrote:
> On Sun, Dec 15, 2013 at 11:54:43AM +0100, Helge Deller wrote:
>> On 12/15/2013 06:32 AM, Dave Land wrote:
>>> Not sure what's up at debian-ports.org, but I've been trying to 
>>> debootstrap 2 different HPPA machines for the last couple days and 
>>> have been getting a variety of errors (size mismatches, files not 
>>> found when they were there 20 minutes before, etc. etc.) Somebody may
>>> want to look into this before it gets out of hand. Thanks! :)
>> I maybe should add some more background here, and maybe someone
>> here on the list might have an idea on how to proceed.
>> Background is, that Dave and myself have binmnu-uploaded the necessary
>> packages for hppa so that debootstrap worked. Then we proceeded with the necessary
>> packages for sbuild and schroot, so that I now have a buildd installed
>> which should be able to start building packages. I haven't turned it
>> on yet though for the reasons which I explain in a few seconds...  
>> In the meantime we have of course uploaded a few more packages which
>> now currently break debootstrap. This is fixable manually, but I instead
>> of uploading packages manually now, I would prefer to get the buildd
>> going instead... So, Dave Land, please wait a little bit...
>> Now to the reasons why I didn't turned on the buildd yet:
>> We noticed, that when we manually binmnu-upload packages, which are
>> already in the *same version* on debian-ports, then debian-ports ACCEPT 
>> those packages, but if we then try to apt-get-update those later on, this leads
>> to a "size mismatch" error. I do have the feeling, that this is a 
>> problem on debian-ports. I noticed for example that reprepro usually
>> doesn't accept packages of the same version which doesn't seem to be
>> the case on debian-ports.
> This is indeed the case, apt-fptarchive keep the checksums corresponding
> to first package. That said it hasn't really caused any problem so far.
>> So, I'm anxious, that if I start the buildd, it will happily build and upload packages
>> which we already uploaded to debian-ports. If this happens we will get more
>> size-mismatch errors.
> Well if you leave the build daemons handling the uploads, they will not
> build and upload the same package again, and the problem won't happen.

Ok, so we should enable the buildd as soon as possble.
>> A trivial example:
>> On machine buildd.debian-ports.org I run:
>> deller@leda:~$ wb info hello . hppa
>> * hello/hppa
>>   | hello:
>>   |   Package             : hello
>>   |   Version             : 2.8-4
>>   |   State               : Needs-Build
>>   |   Section             : devel
>>   |   Priority            : source
>>   |   Previous-State      : 
>>   |   State-Change        : 2013-02-18 00:03:36.782007
>>   |   CalculatedPri       : 52
>>   |   component           : main
>>   |   Distribution        : sid
>>   |   Notes               : out-of-date
>>   |   State-Days          : 300
>>   |   State-Time          : 25958430
>> So, the package "hello" would need a rebuild according to the wanna-build database,
>> and that would wb probably tell my buildd who then would start building/uploading it.
>> But on http://ftp.debian-ports.org/debian/pool-hppa/main/h/hello/ you can
>> see, that the hello-package is already uploaded at version 2.8-4
>> So, if my buildd now uploads the newly created hello package, I'm sure
>> we will run again into the size-mismatch problem.
> The wanna-build database is not up to date on hppa. I have disabled it
> to save some very precious cpu cycles given there are no buildds on hppa
> yet.

Can you the please start it now again?
This would help me to see what's missing.
>> Now, Aurelien mentioned last week to me, that this size-mismatch error 
>> might be because of the "apt-ftparchive cache might have been corrupted for hppa".
>> I'm not 100% sure about that.
> Ok I wasn't aware the same package have been uploaded multiple time, so
> the corruption comes clearly from there.
>> My question here on the list would be, if you (other arch-porters) do have an idea
>> on how I should proceed.
> I would say stop doing manual upload and start the build daemons.

Will do.
That was even the plan - just upload enough that debootstrap/sbuild/schroot is 
installable which it is now.
>> Best solution would probably be, if the wanna-build database rescans what's in
>> the archive already. Is this possible?
> Yes, I can re-enable the hppa wanna-build database if it is actually
> useful.

Yes, please, turn it on now.
I will send you the hppa buildd gpg/ssh details (as mentioned in your other mail to me) in a few moments.

>> Or, should I just start the buildd and see what's happening? If we then get
>> the size-mismatch errors there is lot of manual work to fix it (unless resetting the
>> apt-ftparchive on debian-ports would solve this).
> We can rebuild the apt-ftparchive database at some point.


Reply to: