[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug in gcc for powerpc?

On Sat, Jul 28, 2012 at 8:34 PM, Roger Leigh <rleigh@codelibre.net> wrote:
> On Sat, Jul 28, 2012 at 04:45:35PM -0400, Felipe Sateler wrote:
>> Hi gcc and powerpc teams,
>> Supercollider recently failed to build in powerpc[1] with some weird
>> errors about operand out of range. Googling around suggests working
>> around the problem by avoiding inlining. And in fact, SC builds after
>> avoiding inlining one function. However, it seems to me this is a bug
>> in gcc, since it shouldn't ouptut invalid assembler. I'm not quite
>> sure how to handle this sort of bug, however. Where should I file this
>> bug (that is, which package)? This bug seems to have happened a few
>> times already, so I'm not quite sure if this is supposed to be fixed
>> or not.
> Just as a data point, I've reproduced this identically on current
> unstable (powerpc).  Have you tried using a different compiler
> version e.g. 4.7?  I can do further investigation tomorrow if you
> would like.

I am testing on partch, I don't have access to other ppc hardware.
Partch has gcc 4.4 and 4.6, it fails with both, with the same error
but in different places (4.4 has lots of errors, 4.6 just 2).


Felipe Sateler

Reply to: