[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Video Card Help - IBM POWER5

On 23 Jan 2012, at 23:14, Pat Wall wrote:

> On 23/01/12 22:18, Lennart Sorensen wrote:
>> On Mon, Jan 23, 2012 at 09:39:51PM +0000, Mark Benson wrote:
>>> I finally got a bootable Debian 6.0.3 system. It's a good start!
>>> I now find myself stuck in another hole.
>>> Xorg doesn't like either my GXT6500P or my GXT135P graphics boards. It doesn't seem to have a driver for either.
>>> I am also totally lost with Xorg. I have hacked good ole' X11R6 with .conf files in the past but this new auto-configuring system is beyond me, I don't even know where to put a xorg.conf to get it to read it in?
>> /etc/X11/xorg.conf should work.
> Here is my working xorg.conf [1] from an Intellistation 285 and GXT135P with Debian 6.0.3. I could only get it to work with the fbdev driver - mga just wouldn't play ball at all.

Excellent! Thanks :)

I wonder if it's actually a monitor issue Xorg is having as the card is recognised and works but my desktop is at 640x480 @ 8-bit and there are no options available other than that.

> The GXT6500 will only work with the CruxPPC patch which is on their install CD (never tried it).

Interestingly it almost works in Xorg - the colours are a mile off though :)

> As a matter of interest what did you do to get yaboot up and running? If I am remembering correctly I had to open a virtual console at the end of the installation and type dd if=/usr/lib/yaboot/yaboot of=/dev/sda1 to copy yaboot to the PReP partition.

That's the method that's supposed to work. I never actually got that far.

I installed Crux, which has instructions (that work, shock horror!!) to install it by hand. I screwed uop when I was installing CruxPPC because x86 force of habit made me add a /boot partition and apparently that's not a good idea!. I then booted the Debian 6.0.3 DVD, wiped out all the partitions except the PReP partition and installed Debian, skipping the bootloader phase when it borked on the Apple_Bootstrap partition error. I then popped into a terminal, copied the /cdrom/etc/yaboot.conf over, chroot'd to my new system partition and hacked the yaboot.conf about to get a usable yaboot.conf using the full kernel and initrd images in / . Worked after a few aborted attempts while I learned my yaboot syntax. Seriously long-winded though! :)


Mark Benson

Twitter: @DECtecInfo

Online Resource & Mailing List for DEC Enthusiasts.

Reply to: