[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

vlc built with --disable-altivec works where the sid one does not - iMac G3


Since after vlc 0.8.6 it didn't play any video file yielding "Illegal
Instruction", audio only files were playing OK. From time to time I
tried to build from source with no luck for one reason or another until
last weekend when I ran:

# aptitude build-dep vlc

after some version leveling I was able to run:

$ ./configure --disable-altivec --disable-optimizations
$ make
# make install

and vlc was playing and streaming (what I really want it to do) video
again. Then I tried:

# make uninstall ; make clean

$ ./configure --disable-altivec

and everything still works!

My hardware is an iMac G3 - 333MHz
# cat /proc/cpuinfo 
processor	: 0
cpu		: 740/750
temperature 	: 34-36 C (uncalibrated)
clock		: 333.333330MHz
revision	: 2.2 (pvr 0008 0202)
bogomips	: 33.32
timebase	: 16664166
platform	: PowerMac
model		: iMac,1
machine		: iMac,1
motherboard	: iMac MacRISC Power Macintosh
detected as	: 79 (Unknown Paddington-based)
pmac flags	: 00000000
L2 cache	: 512K unified
pmac-generation	: NewWorld
Memory		: 384 MB

What package should I report a bug against, if any?


"...agora, só nos sobrou o futuro...", visto em www.manuchao.net

Gunther Furtado
Curitiba - Paraná - Brasil

Reply to: