[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: trouble netbooting debian on xserver g4 ppc cluster node


Thanks very much for the help Tom and Benjamin, Tom that wiki you pointed us to really helped us get things going and explained the process clearly. And Benjamin your tips and example dhcpd.conf file ended up solving the last issues we ran into, so I can't thank you enough. 

We ended up going with a simple dhcpd.conf file
ddns-update-style interim;
allow booting;
allow bootp;

subnet netmask {
        default-lease-time 600;
        max-lease-time 7200;

group {
        option routers;
        filename "/tftpboot/yaboot";

        host node0 {
                hardware ethernet <our xservs mac address>;
Placed all the files in the root of the tftpboot directory 

initrd.gz, vmlinux, yaboot (These 3 files came from this site here)

yaboot.conf (came from from the wiki page but we had to modify it as follows (we combined some of the parts from the current yaboot.conf  file) ):
init-message="Debian GNU/Linux Network boot"


Once we had this setup we did a "boot enet:0,yaboot" from OpenFirmware on the XServe and it worked great. 


On Tue, Jan 11, 2011 at 7:17 PM, Patrick Boutet <pat.boutet@gmail.com> wrote:
I only had an hour today to work on it and I ran into a small tftp issue which I will resolve when I try again on Thursday, so I still didn't get it working. But with the suggestions of Tom and now your's Bejamin I think were really close. I'll check the logs again and compare the DHCP config file to my own and hopefully this should work on Thursday.

Thanks again for the suggestions, I'll keep everyone posted on how it goes.


On Tue, Jan 11, 2011 at 5:15 PM, Benjamin Cama <benoar@free.fr> wrote:

Netbooting iBook/PowerBook has always been strange to me, so here are my
advices :

> Can anyone offer any guidance as to what files to
> place in the tftpboot directory? We are assuming vmlinux, initrd.gz, yaboot,
> yaboot.conf and boot.msg from
> http://http.us.debian.org/debian/dists/lenny/main/installer-powerpc/current/images/powerpc/netboot/
> is
> this right or wrong? What should the directory structure look like?

All these files should just be at the root of your tftp directory. No
need for the gtk directory if you don't use the graphic installer.

> Next, what do we do for the part that says"You may have to make a link from
> that file to the file which tftpd will use for booting a particular client.
> Unfortunately, the file name is determined by the TFTP client, and there are
> no strong standards."  We really don't know what to do for this part. When
> it mentions TFTP client does it mean the one that the xserver uses, does
> OpenFirmware use a client somehow? Because were attempting to initiate
> booting from TFTP through Open Firmware on the xserver via "boot enet:0" and
> "boot enet:0,yaboot" both of which did not work. Were assuming because we
> don't have the right files and in the right structure in the tftpboot
> directory.

I recall using "boot enet:0,yaboot" with succes (maybe with no 0? but
still, "yaboot" as a file name is needed, I think).

> Any advice on how to get this xserver to netboot would be amazingly helpful,
> we've been fighting with it for many weeks now and not getting anywhere :(

The main issue, for me, was the DHCP server configuration, as my
PowerBook seems to need some guidance. An excerpt from my dhcpd.conf
(using a addressing on the server):

 group {
        option routers;
        filename "yaboot";
        server-name "myservername";

        host powerbook {
                hardware ethernet <mac address of your G4>;

Just replace "myservername" with the DNS name of your server, replace
"powerbook" with anything you like, and put the mac address of the
computer you're netbooting at the right place.
I'm not sure if everything is needed, but it's what I found lying in my
config file.


Reply to: