[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Booting kernel on IBM RS/6000 7043 model140


2010/7/7 Gary <gdriggs@gmail.com>:
> There's a chance you might get Crux PPC to work but NetBSD/prep is
> probably the most current of anything you'll find for your particular
> system.

After looking at the Crux/PPC documentation, it seems that it has no
support for PReP machines.

> If you want to continue with Linux, however, have a look at these older documents:
> http://www.solinno.co.uk/7043-140/getstarted.php
This was the page, that I looked at first, however it doesn't say
anything useful about CD-ROM booting.

> http://www.debian.org/ports/powerpc/inst/prep
This page doesn't have much relevant information on my problem,
instead it contains information about network and floppy booting.

Yesterday I tried booting the openSuSE 10 PPC port, and it looked
quite promising, yet sadly it too got stuck somewhere along the
booting process.

RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000
RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000

     memory      keyboard     network      scsi      speaker       ok
0 > boot cdrom:,\boot\zImage.prep.initrd

CLAIM failedclaim 0xffdaa188@0x01000400 returned 0xffffffff
vmlinux buffer @ 0x00e00000
stdin  '/pci@80000000/isa@b/serial@i3f8'
type   'serial'
stdout '/pci@80000000/isa@b/serial@i3f8'
zImage.prep starting
Open Firmware: 0x0021a0c0
stack at:      0x00daa480 0x00500030
loaded at:     0x01000400 0x015aa988
relocated to:  0x00800000 0x00daa588
zimage at:     0x00809945 0x009d318f
initrd at:     0x009d4000 0x00d95521
edit kernel cmdline within 10 seconds and press RETURN:
sysrq=1 nosshkey console=ttyS0 minmemory=1 MemYaSTText=1 quiet 1 text -
uncompressing kernel done. (0x003fc86c bytes)
birecs @ 0x00500000
Now booting the kernel
You may not see any kernel console output,
use a serial console on COM1 in this case.
append 'console=ttyS0' to the kernel cmdline
Total memory = 768MB; using 2048kB for hash table (at c0600000)
Linux version 2.6.13-15-default (geeko@buildhost) (gcc version 4.0.2
20050901 (prerelease) (SUSE Linux)) #1 Tue Sep 13 14:56:15 UTC 2005
PReP architecture
IBM planar ID: d5
MPIC at 0xfdbc0000 (0x3dbc0000), length 0x00040000 mapped to 0xeffc0000
Built 1 zonelists
Kernel command line: sysrq=1 nosshkey minmemory=1 console=ttyS0
MemYaSTText=1 text -
OpenPIC Version 1.0 (4 CPUs and 16 IRQ sources) at effc0000
PID hash table entries: 4096 (order: 12, 65536 bytes)
time_init: decrementer frequency = 16.621414 MHz
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 768512k available (2828k kernel code, 1580k data, 188k init, 0k highmem)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Mount-cache hash table entries: 512
checking if image is initramfs... it is

It may be that the firmware environment variables (eg. load-base and
real-base) are set up in a wrong way. I also tried the setting
recommended on http://www.solinno.co.uk/7043-140/getstarted.php
My current firmware variables are as follows:

0 > printenv
little-endian? *         false               false
real-mode? *             true                true
auto-boot? *             true                true
diag-switch? *           false               false
fcode-debug? *           false               false
oem-banner? *            false               false
oem-logo? *              false               false
use-nvramrc? *           false               false
real-base                -1                  -1
real-size *              400000              400000
virt-base *              -1                  -1
virt-size *              400000              400000
load-base                1000000             600000
pci-probe-list *         -1                  -1
screen-#columns *        64                  64
screen-#rows *           28                  28
selftest-#megs *         0                   0
ibm,fw-default-mac-address? * false          false
ibm,fw-hrp-memmap? *     false               false
ibm,fw-xoff-enable? *    true                true
ibm,fw-pnp-isa? *        true                true
ibm,fw-obe-audio? *      true                true
ibm,fw-full-memory-test? * true              true
boot-device *            floppy              floppy
boot-file *
diag-device *            floppy              floppy
diag-file *              diags               diags
input-device             com1                /pci/isa/serial
output-device            com1                /pci/isa/serial
ibm,fw-mouse-device      nomouse             nomouse
oem-banner *
oem-logo *
nvramrc *
boot-command *           boot                boot
fw-scsicfg *
ibm,fw-n-bc *  
ibm,fw-n-bretry *        00                  00
ibm,fw-n-tretry *        00                  00
ibm,fw-n-dbfp *          00000000            00000000
ibm,fw-n-dafp *          00000000            00000000
ibm,fw-n-rc *            A                   A
ibm,fw-n-ru *            Y                   Y
ClientIPAddr * 
ServerIPAddr * 
GatewayIPAddr *
NetMask *      
ibm,fw-dc-select         16b4                0
fw-language *            english             english
boot-script *
diagnostic-mode? *       false               false
security-#badlogins *    0                   0
security-mode *          0                   0
security-password *
menu? *                  true                true
reboot-command *
ibm,fw-timebase-freq     66485656
ibm,0006292e8a71         10,full
ibm,fw-pci-hint,011018   00541014 ff000000
fw-keyswitch             normal
fw-boot-device           /pci@80000000/pci1000,3@10,0/cdrom@3,0

I will also try to strip down my config to a bare minimum, removing
any add-on cards, hard drives, memory modules, and will see if that
helps anything...

And finally, this is what NetBSD said during boot:

RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000
RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000

     memory      keyboard     network      scsi      speaker       ok
0 > boot cdrom:

>> NetBSD/prep BOOT, Revision 1.8
>> (builds@b7.netbsd.org, Sat Feb  6 20:42:39 UTC 2010)

Loading in()

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 5.0.2 (INSTALL) #0: Sat Feb  6 20:53:42 UTC 2010
Model: IBM Model 7042/7043 (ED)
total memory = 768 MB
avail memory = 740 MB
OpenPIC Version 1.1: Supports 4 CPUs and 16 interrupt sources.
mainbus0 (root)
cpu0 at mainbus0: 604e (Revision 2.3), ID 0 (primary)
cpu0: HID0 c084<ICE,DCE,SGE,BHT>, powersave: 1
cpu0: 233.34 MHz
pnpbus0 at mainbus0
mcclock0 at pnpbus0: port 0x70-0x71, irq 8: mc146818 compatible
time-of-day clock
nvram0 at pnpbus0: port 0x74-0x75 0x76
pci0 at mainbus0 bus 0: indirect configuration space access
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x1057 product 0x0002 (rev. 0x30)
pchb0: L2 cache: 1M, internally controlled write-back mode
pcib0 at pci0 dev 11 function 0: vendor 0x1014 product 0x000a (rev. 0x03)
pcn0 at pci0 dev 12 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c970A PCnet-PCI II rev 6, Ethernet address 00:06:29:2e:8a:71
pcn0: interrupting at irq 22
pcn0: 10base5, 10base5-FDX, 10baseT, 10baseT-FDX, auto, auto-FDX
vendor 0x1014 product 0x0046 (undefined subclass 0x00) at pci0 dev 13
function 0 not configured
siop0 at pci0 dev 16 function 0: Symbios Logic 53c825a (fast wide scsi)
siop0: using on-board RAM
siop0: interrupting at irq 23
scsibus0 at siop0: 16 targets, 8 luns per target
ppb0 at pci0 dev 23 function 0: vendor 0x1014 product 0x0022 (rev. 0x01)
pci1 at ppb0 bus 1
pcn1 at pci1 dev 1 function 0: AMD PCnet-PCI Ethernet
pcn1: Am79c971 PCnet-FAST rev 6, Ethernet address 00:06:29:dc:99:62
pcn1: interrupting at irq 21
nsphy0 at pcn1 phy 1: DP83840 10/100 media interface, rev. 1
nsphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ukphy0 at pcn1 phy 31: Generic IEEE 802.3u media interface
ukphy0: OUI 0x000058, model 0x0001, rev. 1
ukphy0: 10baseT, 10baseT-FDX, auto
vendor 0x1014 product 0x0054 (miscellaneous display, revision 0x01) at
pci1 dev 2 function 0 not configured
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com0: console
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0 (mux ignored)
biomask 800009c netmask 800009c ttymask 800009c
scsibus0: waiting 2 seconds for devices to settle...
cd0 at scsibus0 target 3 lun 0: <IBM, CDRM00203\000\000\000\000\000!K,
1.00> cdrom removable
cd0: sync (100.00ns offset 8), 8-bit (10.000MB/s) transfers
sd0 at scsibus0 target 4 lun 0: <IBM, DCHS04U, 6363> disk fixed
sd0: 4303 MB, 6077 cyl, 9 head, 161 sec, 512 bytes/sect x 8813870 sectors
sd0: sync (100.00ns offset 8), 16-bit (20.000MB/s) transfers, tagged queueing
sd1 at scsibus0 target 5 lun 0: <SEAGATE, ST34572WC, HP03> disk fixed
sd1: 4095 MB, 6300 cyl, 8 head, 166 sec, 512 bytes/sect x 8388314 sectors
sd1: sync (100.00ns offset 8), 16-bit (20.000MB/s) transfers, tagged queueing
Kernelized RAIDframe activated
boot device: cd0
root on md0a dumps on md0b
root file system type: ffs
WARNING: clock gained 150 days
erase ^H, werase ^W, kill ^U, intr ^C, status ^T
Terminal type? [vt100]
Erase is backspace.
(I)nstall, (S)hell or (H)alt ? s


Reply to: