[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Segmentation fault at start-up


I have a powerpc iBook G4 mid2005, on wich I use Debian Sid. I run the
2.6.32-5 kernel from the repository. I have a separate boot partition,
and my / and home in lmv.

Today I rebooted, and now after the machine starts up again, I see the
following message:

Loading, please wait...
Segmentation fault
Segmentation fault

After a few minutes, I receive  a message saying that the kernel cannot
find the root partition.

ALERT! /dev/mapper/pomme-root does not exist. Dropping to a shell!

Then I get to Busybox. Apparently, LVM is failing. But I can see that
the dm-mod module is loaded (in /proc/modules).

I tried reinstalling yaboot, regenerating the initramfs image,
installing a new kernel, but nothing has helped so far.

Did anybody encounter this problem before? Can anyone advise me on this?

Thanks in advance.


Attachment: signature.asc
Description: Digital signature

Reply to: