[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Semi-OT] using a "ppc" disk on a x86 box


I'd like to read on a x86 box a disk I used on a pegasos2 box. I'm
going to use the disk through a pata2usb external box.

I tried plugging the disk in. The system detects the disk (sda) but not
the partitions (sda1, sda2, etc.).

I wanted to check if the external box was working properly. So I used
the external box with a dos partitioned disk and the system could detect
the partitions successfully.

At first I thought it was somehow related to "CONFIG_MAC_PARTITION". I
gave for granted it was enabled but it wasn't. So I recompiled the
kernel. Now it's enabled, but the system still doesn't detect the

Somebody suggeted installing "mac-fdiks". As far as I know that would
help only if I wanted to edit the partition table but "mac-fdisk"
itself doesn't let the system to detect the partitions (does it?).

Somebody else suggested enabling "CONFIG_BSD_DISKLABEL". I don't know
what it is for though.

Another thing that came to my mind was "CONFIG_AMIGA_PARTITION" but on
no strong basis. Just because, if I recollect correctly, morphos was
somehow based (but I'm really not sure about that) on amiga or something
like that.

Could anybody please give me a pointer?

Thanks in advance.

Best regards.

Value your freedom, or you will lose it, teaches history.
``Don't bother us with politics,'' respond those who don't
want to learn.

 -- Richard M. Stallman

Attachment: signature.asc
Description: PGP signature

Reply to: