[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installed Lenny on a Apple MacPro G5. Install: OK, did not boot the Kernel after.

On Wed, 29 Apr 2009 14:05:27 +0800
Louie Miranda <lmiranda@gmail.com> wrote:

> After installation, then it reboots.
> It shows the boot prompt l for linux or c for cdrom. When it boots to
> l for linux, there are three dots ... then after a few seconds it
> loops again on the boot prompt. I think the kernel cannot be seen?
> --
> Louie Miranda (lmiranda@gmail.com)
> http://www.louiemiranda.net
> Quality Web Hosting - www.axishift.com
> Pinoy Web Hosting, Web Hosting Philippines
> On Wed, Apr 29, 2009 at 1:58 PM, Amit Uttamchandani
> <amit.uttam@gmail.com>wrote:
> > On Wed, 29 Apr 2009 11:38:56 +0800
> > Louie Miranda <lmiranda@gmail.com> wrote:
> >
> > > Hi, I am trying to install Debian 5 Lenny on a Apple MacPro G5.
> > >
> > > Installation was successful, however upon rebooting. It won't
> > > load the kernel. I tried to go back to boot again the CD and
> > > tried to mount the system, and it did.
> > >
> > > I am lost why the kernel did not boot properly?
> > >
> > > Help!
> >
> > Are there any error messages? What happens? Does it get stuck
> > somewhere or does it simply not find the kernel?
> >
> >
> > --
> > To UNSUBSCRIBE, email to debian-powerpc-REQUEST@lists.debian.org
> > with a subject of "unsubscribe". Trouble? Contact
> > listmaster@lists.debian.org
> >
> >
It could be a corrupt yaboot.conf if it like this


Place a Debian CD in the tray and boot with the C key held down.

After the white open firmware screen you should get the black yaboot
screen with a prompt like this. boot: type:

rescue <hit enter>

Enter your language
Enter you keyboard layout
Enter your key map
Enter hostname <if you don't know or care just hit enter>
Enter domain name <if you don't know just enter "local" minus quotes
then hit enter> Then you are given a list of partitions on your machine
and asked for your root partition select your root partiton. If you
don't know which partition is your root partition do this. Note
sometimes the ALT and OPT keys are inter changable depending which part
of the world you live. KEYS:

CTL+ALT F2 <all at the same time>

This will give you a console with a prompt like this #

 mac-fdisk -l

This will list all partitons, as an example mine is below. look down
YOUR list until you see your root partition

type name                  length   base      ( size )  system@
/dev/hda1     Apple_partition_map Apple                     63 @
1         ( 31.5k)  Partition map /dev/hda2         Apple_Bootstrap
untitled                1954 @ 64        (977.0k)  NewWorld
bootblock /dev/hda3         Apple_UNIX_SVR2 root
18554688 @ 2018      (  8.8G)  Linux native /dev/hda4
Apple_UNIX_SVR2 swap                  976563 @ 18556706  (476.8M)
Linux swap /dev/hda5         Apple_UNIX_SVR2 home
62500001 @ 19533269  ( 29.8G)  Linux native /dev/hda6
Apple_UNIX_SVR2 untitled            78038390 @ 82033270  ( 37.2G)
Linux native /dev/hda7              Apple_Free Extra
14868 @ 160071660 (  7.3M)  Free space

On mine /dev/hda3 is root. Note yours down.

CTL+ALT F1 <all at the same time>

This will put you back into rescure mode and you can select your root
partition From the next menu, using the up and down arrows select
"Reinstall yaboot boot loader" <hit enter>

Hopefully :) a message saying "Succesfully installed yaboot" will apear
<hit enter> From the next menu select "Reboot the system" <hit enter>


Reply to: