[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian on a pSeries Power6 anyone?

Hello all,

today i tried to move a LPAR w/ Debian Lenny from a p570 (Power5+) to
a p550 (Power6). The system resides on VIO-mapped SAN disks, so moving
it wasn't a big deal. Unfortunately it bails out pretty early in the
boot process with:
  "unable to open file, Invalid device"
on the kernels "root="-device. Trying to access it via CD-booted rescue
mode - no problems. Moving it back to the p570 - no problems booting
the system. The disk device IDs are exactly the same on both systems:
  /vdevice/v-scsi@30000002/disk@8100000000000000 (sda)
  /vdevice/v-scsi@30000003/disk@8200000000000000 (sdb)
I double checked that. The precautionary update-initramfs and ybin from
the rescue system booted on the p550 didn't help either.
Next i set up a blank LPAR on the p550 and installed Debian Lenny from
scratch. As with the rescue boot, the install itself went fine, but the
following initial boot failed with the same error as above.
I wonder if anyone else got Lenny to work on a Power6 machine? Is this
another case (i read some hints on similar problems) where a newer ya-
boot version is necessary?

Thanks & best regards,


Reply to: