[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

net problem, some apps not connecting


I have a g4 notebook. It had not been connected to any network for a while.
Now i tried to conect to a network.
The problem is the same in any network (wired or wireless, at home or work). So is not the network.
It have dual boot (linux-osX). The problem is just in linux, so is not the hardware.
It must be some configuration problem.

The symptoms:

It "can't conecct" to any other computer.

I have tried the following browsers: iceweasel, iceape, konqueror, opera, lynx and links.
All have failed conecting to any webpage.

I have tried to connect via ssh (ssh, slogin, scp) to any other box in the net, all have failed. (I can't connect either to that box) Simply, ther is no answer.

You can say it is the connection or dns or something, BUT:

I can ping any other computer. Even the gateway or dns.

If i type: "host mail.yahoo.com" or "dig mail.yahoo.com" or "host www.hotmail.com" or any other with host or dig, i get the answer.

If i type "nc any.ip.in.net 22" i get the ssh answer (SSH-2.0-OpenSSH_4.3p2 Debian-9)

If i type "wget http://www.google.com"; I get the index.html that is google page. I can wget any page or file.

I can "aptitude update" and "aptitude safe-upgrade" whitout any trouble.

So the box is connecting to the net with some apps, but other apps are not connecting.

There is no iptables nor proxies. There is any fixed arp table.

The problem is the same if i connect the box direct to other box and i tried to connect via ssh or webpage.

Any ideas? Some config file i'm missing?



Reply to: