[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#423721: kernel-package: [Powerpc] Not just bogus version-# annoyance: deb build fails with CONFIG_LOCALVERSION_AUTO=y

Package: kernel-package
Version: 11.001
Followup-For: Bug #423721

Hi All

Similar to #390924 the compile completely fails with git kernels as
long as LOCALVERSION_AUTO is turned on. But other than on #390924 the
fail does no seem to have anything to do with GREP_OPTIONS in the
user's environment being exported.

For example, having disabled in a rather fresh git tree
CONFIG_LOCALVERSION_AUTO the compile will finish cleanly in an
environment where GREP_OPTIONS are exported like so:

env | grep -i grep

In the same xterm, with the env values from above, I can successfully
compile a git-kernel, as long as I have CONFIG_LOCALVERSION_AUTO
switched off.
The kernel where this worked:
git branch -v
* master fd0b45d Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net-2.6

Output "head -6 Makefile" in the tree where the compile worked: 
$ head -6 Makefile
NAME = Arr Matey! A Hairy Bilge Rat!

The command used for the build:

time MAKEFLAGS="CC=gcc-4.1" fakeroot make-kpkg --append-to-version=-2008.01.10.a --revision +2nd.no.localversion+env.with.grep kernel_image

Result, IINM:


As soon as I switch on CONFIG_LOCALVERSION_AUTO in the kernel .config,
the deb kernel package build will fail with errors similar to the ones
below: and it does not seem to matter whether GREP_OPTIONS are
exported or not:

echo done > debian/stamp-build-kernel
====== making target
install/linux-image-2.6.24-rc7-2008.01.10-gfd0b45df-dirty-gfd0b45df-dirty-dirty [new
prereqs: ]======
This is kernel package version 11.001.
echo "The UTS Release version in include/linux/utsrelease.h"; echo "
\"2.6.24-rc7-2008.01.10-gfd0b45df-dirty\" "; echo "does not match current version:"; echo
"     \"2.6.24-rc7-2008.01.10-gfd0b45df-dirty-gfd0b45df-dirty-dirty\" "; echo "Please
correct this."; exit 2
The UTS Release version in include/linux/utsrelease.h
does not match current version:
Please correct this.
make: ***
[install/linux-image-2.6.24-rc7-2008.01.10-gfd0b45df-dirty-gfd0b45df-dirty-dirty] Error 2

Interestingly enough this .deb build fail did not always seem to
happen with CONFIG_LOCALVERSION_AUTO turned on:

This package:


was built in August 2006 with CONFIG_LOCALVERSION_AUTO=y ... :)

We had a small discussion on the subject on the powerpc list over the
last hours, with a few more details, hopefully:

"make-kpkg "utsrelease.h ... does not match current version"

Please let me know if you need more information.

Best Regards

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.18-rc4-060811-dirty
Locale: LANG=C, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages kernel-package depends on:
ii  dpkg                          1.14.12    package maintenance system for Deb
ii  dpkg-dev                      1.14.12    package building tools for Debian
ii  file                          4.21-3     Determines file type using "magic"
ii  gcc [c-compiler]              4:4.2.1-6  The GNU C compiler
ii  gcc-4.0 [c-compiler]          4.0.3-7    The GNU C compiler
ii  gcc-4.1 [c-compiler]          4.1.2-17   The GNU C compiler
ii  gcc-4.2 [c-compiler]          4.2.2-4    The GNU C compiler
ii  gettext                       0.16.1-2   GNU Internationalization utilities
ii  make                          3.81-3     The GNU version of the "make" util
ii  perl                          5.8.8-12   Larry Wall's Practical Extraction 
ii  po-debconf                    1.0.10     manage translated Debconf template

Versions of packages kernel-package recommends:
ii  bzip2                         1.0.3-7    high-quality block-sorting file co
ii  libc6-dev [libc-dev]          2.7-3      GNU C Library: Development Librari

-- no debconf information

Reply to: