[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X server lock up after upgrade to 7.3


I have an Apple iBook G3 (latest model before G4) . I'm running debian 
unstable on it. Yesterday I upgraded the xorg xserver from something old 
(think it was 6.9) to 7.3. After that I tried to upgrade KDE. Suddenly 
while selecting packages in aptitude the system locked up. I could move 
the mouse pointer but nothing else worked. I rebooted, switched to console 
mode and finished the upgrade, hoping this would solve the problems. 
Unfortunately not.

I tried the usual suspects: disabling frequency scaling and building a new 
kernel (2.6.15 -> 2.6.22). But nothing so far helped.

Here are my observations:
1. console mode still works fine
2. not using KDE but a rudimentary X11 setup seems to work
3. if I start KDE and open a file with kate, I can trigger the lock up by 
just moving the scrollbar up and down a few times.
4. I can still telnet into the system.
5. sometimes the X server ist at 100% cpu, sometimes everything is quite.
6. sometimes I see a lot of the following error messages in Xorg.0.log:
	tossed event which came in late
	mieqEnequeue: out-of-order valuator event; dropping.
7. only a reboot will restore the console

Does somebody have a cure for this? Like downgrading some part? Or a 
configure thing?

I start KDE

Reply to: