[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Solved .. :)] Re: KDM/KDE Login screwed after dist-upgrade today



Hi Michel

Thanks a lot. :)

On Thu, May 04, 2006 at 06:24:25PM +0200, Michel Dänzer wrote:
> On Thu, 2006-05-04 at 17:30 +0200, Wolfgang Pfeiffer wrote:
> > 
> > On tty1 I enter a 
> > /etc/init.d/kdm start
> > 
> > After getting the KDM/KDElogin screen I type in my password for an
> > underpriviledged user, try to login with that, the login screen
> > disappears, the display is getting black, and I'm thrown back at the
> > same login screen again.
> > 
> > And yes, auth.log says that the login was OK, something like:
> > 
> > .. session opened for user [ .. ]
> > .. session closed for user [ .. ]
> > 
> > 
> > The culprit must be in one of the packages next below, that I upgraded
> > today. And IIRC this issue happened *only* after that upgrade:
> 
> [...]
> 
> > -rw-r--r-- 1 root root    920 May  4 15:23 x11-common.list
> 
> [...]
> 
> > ii  xserver-xorg                                  7.0.16
> 
> x11-common 1:7.0.16 has a bug (that's been reported about a dozen times,
> so don't bother ;) that removes /etc/X11/Xsession. Try
> 
> sudo dpkg -i --force-confmiss /var/cache/apt/archives/x11-common_1%3a7.0.16_powerpc.deb

dpkg -i --force-confmiss /var/cache/apt/archives/x11-common_1%3a7.0.16_powerpc.deb

.. helped. And not having to write a bug report, besides having KDE
up and running again, is the best part of it  ... :)

Thanks again .. :)

Best Regards
Wolfgang

-- 
Wolfgang Pfeiffer: /ICQ: 286585973/ + + +  /AIM: crashinglinux/
http://profiles.yahoo.com/wolfgangpfeiffer

Key ID: E3037113
http://keyserver.mine.nu/pks/lookup?search=0xE3037113&fingerprint=on



Reply to: