[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian install on biege G3

On Tue, Dec 06, 2005 at 10:15:48AM +0000, David Pead wrote:


> The only option I've had limited success with is the net-install. This
> progesses but falls over after re-start when I put the relevant info into
> BootX.
> -------------------
> Hans, MANY thanks for your reply,
> [snip]
> The kernel you boot with via BootX needs a initrd to work. I think the
> init in the initrd will find out which root partition it should use.
> So don't use root=/dev/sda7 but root=/dev/ram and initrd=<initrd.img>
> where <initrd.img> is a file available for BootX with the initrd.
> BTW. I have recently figured out how to configure OF to work with
> quik, and I only need to set one parameter, the boot-device parameter.
> So if you want to I give some advice on how to configure OF so you
> won't need to boot via MacOS.
> [/snip]
> Tried your suggestion, I wasn't sure where to put which bits (ie root device
> or kernal arguments) so tried every permutation. No luck, I must be
> missing/lacking something!

I have not done this recently, so some parts might be wrong. I
addition to that, I don't have access to bootX right now, so this is
from my memory only :-)

I think you cannot boot into your installed system with the kernel
used to install it. Instead you should boot with the kernel that was
installed during the installation. However that kernel resides on a
linux partion now available for BootX. You must somehow copy it, and
the it's companion initrd.img to the MacOS partion where BootX

So restart the installation, press ctrl-alt-F2 and <enter> to get a
shell. Mount the MacOS-partition where BootX resides. copy
/boot/vmlinux (or possibly vmlinux.gz) and /boot/initrd.img to the
folder were BootX looks for kernels (might be something like "System
Folder/Linux kernels/")

Then umount the MacOS-partition and reboot into MacOS and start BootX.

There is a checkbox for the initrd or "ramdisk", named something like
"use specified file for ramdisk..." chose initrd.img

Assure yourself that vmlinux (or vmlinux.gz, don't remember) and
initrd.img are the new ones and not the ones that will start the

the root device should be /dev/ram, but I think that's all.

> I'll take you up on your offer of a Quik walkthrough, if you please.

No, as Simon pointed out, there is known, unsolved problems with quik
and (some of?) the beige G3:s. Focus on BootX for now.

Hans Ekbrand (http://sociologi.cjb.net) <hans@sociologi.cjb.net>
Q. What is that strange attachment in this mail?
A. My digital signature, see www.gnupg.org for info on how you could
   use it to ensure that this mail is from me and has not been
   altered on the way to you.

Attachment: signature.asc
Description: Digital signature

Reply to: