[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hfs+ redux

On Thu, 2005-09-29 at 09:51 -0700, Kim Cascone wrote:
> I just tried a little experiment:
> - formatted a 300G HD using Disk Utilities in OS X (10.3.9) on a G5 iMac
> 	- 290G=HFS+
> 	- 10G=Unix FS
> dragged a foo.tar.gz file to the Unix part
> dragged a pdf to the HFS+ part
> unmounted the drive
> plugged the drive into my iBook which was booted into UbuntuPPC 5.04
> the Nautilus file browser saw both parts of the HD
> but gparted only saw one large 300G space on the HD; it couldn't see 
> the Unix FS or the MacOS X part
> I unmounted the drive from the Linux PPC
> mounted it again on the iMac
> the 300G drive did not mount on the desktop
> using Disk Utils I saw the Unix part but the OS X part was hosed

Hosed, how so ? what does Disk Utils says specifically ? I mount HFS+
partitions regulary here without problems. However, make sure it's not
journaled. Also, OS X has a new "HFSX" that may have issues with linux
support, I haven't tried.
> anyone else have this experience?
> is it possible to do backups from LinuxPPC and OS X on to one drive 
> part'd into ext3 and OS X?

I wonder if you are simply having firewire problems, difficult to say...

Do you see any error in linux dmesg ?

If not, I would recommend you send a detailed report to Roman Zippel
<zippel@linux-m68k.org>, the linux HFS+ maintainer


Reply to: