[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: iBook G3 owners

On Sat, 2005-04-16 at 14:36 -0700, Steve Freitas wrote:
> Okay, I'm using 2.6.12-rc2 with your patches as downloaded today. (Don't know 
> what's responsible for the Zilog and dm errors below, I'm using Ubuntu 
> Hoary's config from 2.6.10 brought forward with make oldconfig.) No Firewire 
> or USB devices attached. I'm booting without X ever running and without the 
> radeon module loaded. I've pasted my lsmod, dmesg and /proc/cpuinfo below.
> The experience has actually been a little bizarre. The first time I tried 
> waking it up (with HAL running), it put some stuff about radeon and eth0 on 
> the screen and then froze. Couldn't SSH in, caps lock key light was working. 
> I figured I'd try again without HAL and capture the text of this particular 
> error later.
> So I rebooted, turned HAL off, and slept it. I was delighted to see that it 
> woke back up. But when I tried to do anything, it seemed unable to access the 
> disk.

Hrm... can you try to edit
arch/ppc/platforms/pmac_cache.S, and spot that bit of code:

        /* disp-flush L1 */
        li      r4,0x4000
        mtctr   r4
        lis     r4,0xfff0
1:      lwz     r0,0(r4)
        addi    r4,r4,32
        bdnz    1b

And change the line

        lis     r4,0xfff0


        li      r4,0

and tell me if that helps...

Reply to: