[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

results of testing pre-release 2.6.11-0.2 kernel package

Hello Sven,

I tried you new 2.6.11-0.2 kernel packages.  Summary of the problems:
no trackpad, no sound, no fn-key.  Details about my configuration
(dmesg output etc.) can be found at


In addition to the "real" problems below I noticed a small packaging

    voss@quiche [~] ll /lib/modules/2.6.11-powerpc/source
    lrwxrwxrwx  1 root root 98 2005-03-14 12:31 /lib/modules/2.6.11-powerpc/source -> /home/sven/debian/kernel/build/kernel-patch-powerpc-2.6.11-2.6.11/tmp/kernel-source-2.6.11-powerpc

The /lib/modules/2.6.11-powerpc/source link should probably not be in
the package in this form.

I hope this helps,

improvements since 2.6.11-0.1

1) adt746x thermostat works now :-)

problems left

1) the trackpad does not work :-(

  Using the trackpad has no visible effect, no input arrives at
  /dev/input/mice, the X pointer does not move etc.

2) sound does not work

  Everything seems fine at first: alsamixer sees controls labelled
  "master", "headphon", "Mix Boos", "PC Speak", "Auto Mut", "Beep".
  Doing "cat something.wav >/dev/audio" or similar takes the
  appropriate amount of time.  But no sound is actually played :-(

3) the "fn" key has no effect

  I tried "showkey -s" on the console.  Pressing "fn" does not modify
  the the scan codes of other keys and does not emit a scan code

4) suspend does not work

  I tried the following shell script on the text console without X running:
	rmmod ohci1394
	rmmod eth1394
	rmmod ieee1394
	rmmod hci_usb
	/etc/init.d/hotplug stop
	echo disk > /sys/power/state
  The script actually completed, but afterwards the machine hung.  The
  cursor on the text console was still blinking, but all key presses
  were ignored and I had to do a hard reset.

suspicious kernel messages

  The dmesg output contains the following lines which look like error

  - no idea about this:

	Can't get bus-range for /pci@f2000000/cardbus@13, assuming it starts at 0
	PCI: Cannot allocate resource region 0 of device 0001:10:19.0

    Sven suggests that this can be ignored.

  - some EPROTO errors:

	ohci_hcd 0001:10:1b.1: new USB bus registered, assigned bus number 3
	hub 3-0:1.0: USB hub found
	hub 3-0:1.0: 2 ports detected
	usb 1-1: device descriptor read/64, error -71
	usb 1-1: device descriptor read/64, error -71
	usb 1-1: new full speed USB device using ohci_hcd and address 3
	usb 1-1: device descriptor read/64, error -71
	usb 1-1: device descriptor read/64, error -71
	usb 1-2: new full speed USB device using ohci_hcd and address 4
	ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>

  - no idea about this:

	ohci1394: fw-host0: Unexpected PCI resource length of 1000!

    Somebody on debian-powerpc guessed that this can be ignored.

  - maybe the following is connected to the trackpad problem

	input: USB HID v1.10 Keyboard [Apple Computer Apple Internal Keyboard/Trackpad] on usb-0001:10:1a.0-2
	HID device not claimed by input or hiddev
	usbhid: probe of 1-2:1.1 failed with error -5


Attachment: signature.asc
Description: Digital signature

Reply to: