[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with d-i RC2 on BW G3 R2

On Sat, Dec 11, 2004 at 11:55:05PM +0100, Stephane Louise wrote:

The right place for this kind of thing is the debian-boot mailing list, CCing
there. More precisely, you should have made an installation report.

> Hi,
> I tried to test the debian installer RC2 on my computers at home. It 
> went perfectly fine on my G3 iBook Rev2, but on my desktop computer, a 
> good old powerMac G3 B&W Rev2 (with a G4 500MHz upgrade from Sonnet and 
> a Radeon 7000 PCI Mac edition), it stopped after a promising start.
> In fact, it stopped at the end of the basic packages installation, at 
> the kernel installation step. Here is the relevant part of the install.log:
> The following NEW packages will be installed:
>   kernel-image-2.6.8-powerpc module-init-tools
> 0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0B/13.6MB of archives.
> After unpacking 38.9MB of additional disk space will be used.
> Selecting previously deselected package module-init-tools.
> (Reading database ... 7564 files and directories currently installed.)
> Unpacking module-init-tools (from 
> .../module-init-tools_3.1-pre6-1_powerpc.deb)
> ...
> Selecting previously deselected package kernel-image-2.6.8-powerpc.
> Unpacking kernel-image-2.6.8-powerpc (from 
> .../kernel-image-2.6.8-powerpc_2.6.8-6_powerpc.deb) ...
> dpkg-deb (subprocess): error in buffer_read(stream): failed to write to 
> pipe in
> copy: Input/output error
> dpkg-deb: subprocess paste returned error exit status 2
> dpkg: error processing 
> /cdrom/pool/main/k/kernel-patch-powerpc-2.6.8/kernel-image-2.6.8-powerpc_2.6.8-6_powerpc.deb 
> (--unpack):
>  short read in buffer_copy (backend dpkg-deb during 
> `./lib/modules/2.6.8-powerpc/kernel/drivers/isdn/hardware/eicon/diva_mnt.ko')
> Errors were encountered while processing:
> /cdrom/pool/main/k/kernel-patch-powerpc-2.6.8/kernel-image-2.6.8-powerpc_2.6.8-6_powerpc.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)

Mmm, this is ugly, i never saw something such, you sure that you don't have
disk I/O hardware problems or something such ? 

> ln: /target/usr/bin/awk: File exists
> umount: /target/dev/pts: Invalid argument
> umount: /target/dev/shm: Invalid argument
> umount: /target/proc/bus/usb: Invalid argument
> Since I didn't know where to send this kind of messages, I though it was 
> the first place to try and look for a solution.

Nope, wrong, right place is explained in :


Also in /root after your installation, or probably somewhere on your rc2 CD.

> If it can help, I'd better bring to attention that I use an up to date 
> Sarge distribution on this computer, and it works fine. Nonetheless, I 
> still use a 2.4.x kernel on it. I tried once the from Debian, 
> but I had no luck to make it work: at boot stage, the module loading 
> wouldn't work for the IDE interface: CMD Technology Inc PCI0646 (rev 7). 

Did you fill a bug report against the powerpc kernel package ? 

> It is a module in the initrd image and is mandatory to access the IDE 
> disk. But modules fails to load so the kernel fails to mount the root 
> partition and panics (May be I missed something in my installation of 
> the kernel, though).

How did you install it ? It should work out of the box. What is the exact
error message ? Please, do it right and fill a bug report about this.


Sven Luther

Reply to: