[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: TEST: Sleep suppport for iBook G4 & Aluminium PowerBooks (ATI based)

my system : ibook g4 12' 800 running gentoo.


experience against gentoo-dev-sources 2.6.9-r4

patch applied fine (no rejects) after i
symlinked /usr/src/linux-2.6.9-gentoo-r4 to /usr/src/linux-2.6.9

there was a stale directory created from the patch
/usr/src/linux-2.6.9-sleep containing only
arch/ppc/platforms/pmac_cache.S which i copied to my linux-2.6.9
directory after checking it didn't exist on the original tree.

success compiling and installing


first suspend/resume worked. didn't test sound.
2nd crashed my, comp wouldn't respond anymore, rebooted
had to fsck then reboot at next boot. no data loss

3rd time till now (3h after).. sound not working (read bellow)... but
the resume appears working

kernel log my resume experiments :

eth0: suspending, WakeOnLan disabled
radeonfb: suspending to state: 3...
cpufreq: resume failed to assert current frequency is what timing core
thinks it is.
PCI: Enabling device 0000:00:10.0 (0000 -> 0003)
radeonfb: resumed !
Apple USB OHCI 0001:10:18.0 disabled by firmware
Apple USB OHCI 0001:10:19.0 disabled by firmware
enable_irq(29) unbalanced
enable_irq(63) unbalanced
enable_irq(63) unbalanced
eth0: resuming
PHY ID: 4061e4, addr: 0
hda: Enabling Ultra DMA 5
hdc: MDMA, cycleTime: 120, accessTime: 90, recTime: 30
hdc: Set MDMA timing for mode 2, reg: 0x00011d26
hdc: Enabling MultiWord DMA 2
adb: starting probe task...
adb devices: [2]: 2 c4 [3]: 3 1 [7]: 7 1f
ADB keyboard at 2, handler 1
ADB mouse at 3, handler set to 4 (trackpad)
adb: finished probe task...
[drm] Loading R200 Microcode
eth0: Link is up at 100 Mbps, full-duplex.
eth0: Pause is disabled

i tried to reload the alsa modules after, and the sound volume is still
_very_ quiet. actually i believe that the volume for headphones and
normal is swapped. you hear the sound strongly when headphones are
plugged (and headphones are on the table not in your hears) and you hear
a very very quiet sound when you use non headphone mode.

i'm not sure if this is the fault of the 2.6.9 kernel (sound/ppc/pmac.c
was changed on 2.6.9-rc2 if i believe this post : bugged then :
http://lists.debian.org/debian-powerpc/2004/09/msg00414.html) or if this
is the fault of this patch.

I'm up to provide additional information and do tests.

keep the good job!


Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=

Reply to: