[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#279491: No disk detected on an IBM RS6000 7043-260 (sym53c8xx driver)

On Wednesday 03 November 2004 16:36, Alessandro Amici wrote:
> > > [...] it looks like an irq problem, the fact that the d-i uses a
> > > 32bit kernel on a 64bit can well be to be the trigger,
> >
> > A similar problem was fixed for PReP systems a while ago.  Before
> > that, I worked around it by setting CONFIG_SCSI_SYM53C8XX_IOMAPPED.
> >

i recompiled a 2.6.8 power3 kernel with CONFIG_SCSI_SYM53C8XX_IOMAPPED=y and 
managed to load the modified sym53c8xx driver, without any change whatsoever 
to the (buggy) behavior :(

since i had the chance to go on a bit with the hardware detection process 
before loading the SCSI driver, i noticed that the IDE interface fails 
claiming irq problems, as well.

after that i tried, with the help of Sven Luther, to produce a 2.6.8 ppc64 
kernel able to start the d-i. we finally succeeded and with the 64 bit kernel 
the problem disappears completely.

according to a conversation with leighbb and benh on #ppc64 the irq handling 
code in ppc64 has been changed recently. so i'm inclined to think that the 
differences in the irq handling between ppc and ppc64 are the root of the 


Reply to: