[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: TFTP booting a Pegasos

On Sun, Oct 31, 2004 at 03:41:22PM +0100, Turbo Fredriksson wrote:
> I'm trying to install woody (must be woody for
> various personal reasons) but it (the kernel) hangs.

Don't. woody installer knows nothing about pegasos (normal it predates the
first pegasos by about 2 years), and you will get nothing but a world of
troubles with that.

If you really want woody (hint: you don't) i would suggest simply booting
something else (like a d-i installed sarge for example), and then create the
woody partition with debootstrap directly. chroot to it, install the kernel
you want (i would stay with the 2.4 ones, since the 2.6 ones need a modern
module-init-tools which is probably not available easily for woody, meaning a
lot of backports and builds).

Today, and this late in the debian/sarge release process, one must be real
crazy to be installing woody, and i don't recomend it in any way, and in no
way offer support for it on pegasos hardware. So, you are on your own, and
have been warned :).

> I created a 2.6.[489] kernel and made a 'znetboot'
> which I tried to boot (using the root.bin from woody).

Well, what kernel are you using ? what sources, which config options ? 

> This, as said above, hangs with 
> ----- s n i p -----
> gunzipping (0x00010000 <- 0x00806cd8 :0x0097bb8c)...done 3419252 bytes
> 46912 bytes of heap consumed, max in use 46912
> start address = 0x10000
> instantiating rtas at 00600000 ... done
> copying OF device tree...done
> Calling quiesce ...
> returning 0x00010000 from prom_init
> ----- s n i p -----

Well, two possibilities : 

  1) you don't have the pegasos patches in it, and thus it doesn't survive the

  2) your kernel has no framebuffer driver for your graphic card built in, and
  thus you see nothing. connect a serial cable, and investigate what you see
  on the serial console. hint: add console=ttyS1,115200n8 to your kernel boot
  args. hint2: buildin serial console in your kernel.

> And I've also tried a bunch of boot images from the
> sarge ISO...

The sarge boot images need to be booted with the exact kernel that was used to
build them, or the module will fail or bomb at you. Use :


And boot it directly, or use : 


Burn the CD and boot with :

  boot cd install/powerpc/vmlinuz-chrp.initrd

(After having inserted the cd in the drive, obviously).


Sven Luther

Reply to: