[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

pre-rc2 installer on PowerMac 9500 & suggestions


I tried to install sarge using the pre-rc2 floppies from Sven
Short summary: Successful, but not easy

Long version: 
-mounted ATI mach64 into first PCI-slot
-zapped the PRAM using option+command+p+r
-booted using boot.img
-loaded the net and cdrom-drivers
The detection of the network hardware ignored the builtin ethernet
interface, so I used the second console to do a "depmod -a; modprobe
mace". This gave me an eth0. Fine
-Retried "detect network hardware" and deselected everything (a lot of
ide-drivers, ide-cd, etc.) Then the installer successfully got an IP via
DHCP and I chose ftp.freenet.de via http as mirror. No proxy was used. I
(of course ;) selected the "testing" branch. I also downloaded the
pre-rc2-CD before to avoid re-downloading the base-system if I'd have to
restart the installation. If I assume right, ftp.freenet.de was never
used :) (But of course it would be nice if the mace would be detected).
To get the cd-drive working, I had to do "modprobe mesh". (I think I saw
a bug concerning this issue somewhere, so perhaps this is fixed in later
-"detect and mount cdrom" asked again to load all the ide-stuff, I only
had to select isofs. 
-"load installer components from cd" worked, I additionally selected mdcfg
-"partition disks": I planned to use RAID1 on some partitions, but I
wasn't able to create partitions with the type "linux raid autodetect",
so mdcfg complained: "no unused partitions of the type linux raid
autodetect are available". Is it possible to use autoconfiguring RAID on
powerpc or will I have to use the old-style /etc/raidtab way?
Here the partition table:
|         #                    type name                length   base    ( size )  system
| /dev/sda1     Apple_partition_map Apple                   63 @ 1       ( 31.5k)  Partition map
| /dev/sda2         Apple_UNIX_SVR2 /                  1464843 @ 64      (715.3M)  Linux native
| /dev/sda3         Apple_UNIX_SVR2 /bootfs              48829 @ 1464907 ( 23.8M)  Linux native
| /dev/sda4         Apple_UNIX_SVR2 swap                250001 @ 1513736 (122.1M)  Linux swap
| /dev/sda5         Apple_UNIX_SVR2 /var/log            187501 @ 1763737 ( 91.6M)  Linux native
| /dev/sda6         Apple_UNIX_SVR2 /home              1855469 @ 1951238 (906.0M)  Linux native
| /dev/sda7         Apple_UNIX_SVR2 /var/spool          420018 @ 3806707 (205.1M)  Linux native
| Block size=512, Number of Blocks=4226725
| DeviceType=0x0, DeviceId=0x0
All partitions (except sda3 and sda4) were formatted using ext3. sda3 was
formatted using ext2 (see below for the reason).
-"install the base system" worked well
-I selected the 2.4.27-powerpc-pmac kernel, because 2.6 needs an initrd
which isn't supported by quik
-Then some single (IMHO useless) packages were installed, for example
initrd-tools and usbutils
-The installation of quik failed as expected (like in woody): "the quik
bootloader requires the root partition to be formatted using the ext2
fs". I planned to use a single ext2-partition for quik and the kernel (see
http://www.penguinppc.org/bootloaders/quik/ext3.php). So I did the
chroot /target			# enter new installed system
mv /boot /bootfs		# move kernel and quik-parts to the
				#  ext2-partition
ln -s /bootfs/boot /boot	# create symlink (new kernels will go to
				# the correct place)
mkdir /bootfs/etc/		
vi /bootfs/etc/quik.conf	# create quik.conf
quik -vr /bootfs		# install quik
exit				# leave chroot

my quik.conf (using my selfcompiled kernel, see below):
| init-message="mac "
| default=linux
| timeout=50
| root=/dev/sda2
| partition=2
| image="3/boot/vmlinux-"
|         label=linux
|         read-only
|         append="console=ttyS0,38400"

Finally I selected "continue without bootloader" and "finish the installation".
After that I booted from hdd (using OF via serial line). The kernel said:
"opening display /bandit@F2000000/ATY,mach64@D... ok"
but I never got any video. I also tried video=ofonly.
So I build my own kernel ( from kernel.org) without initrd(!!) and installed it via
An excerpt from .config:
| # CONFIG_SERIAL_8250 is not set
Using this, I was able to get the OF, quik and the kernel-messages on
the serial console. I don't know if the configuration of the base-system
would come up on the console because I ran it inside the chroot (when
installing the kernel). While I was in the chroot, I also added
T0:23:respawn:/sbin/getty -L ttyS0 38400 vt100
to /etc/inittab and was finally able to login.

End of long version :)

-Could we add something to guide users to get a ext2-partition for quik?
At least we should warn them after partitioning if / isn't an
-To avoid the problems on oldworld powermacs concerning the video, I
would suggest to build an additional boot-floppy with the
console-parameter mentioned above (but I don't know if the kernel used on
the floppies has the necessary things built in)

Greetings from Munich,

PS: Something strange I noticed while trying some daily-builds: The
root-floppy only ejects when it is NOT write-protected. But then its
content has changed... Any ideas?

| PGP-Key 0x43D23ABE available via www.de.pgp.net, see header for fpr |

Reply to: