[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel 2.6.7: now cdrom problem

On Wed, 15 Sep 2004 the mental interface of
Christina Boeckler told:

> hi

<ESC> qap

> i did not compile my kernel myself, it is the debian sarge image
> 2.6.7 mounting on sr0 or so did not help, neither did any modprobe
> thing, i tried. here is the outcome lsmod with 2.4 and 2.6 and of
> mount /cdrom on 2.6.
> appart from the cdrom i am very happy with the gain of speed with
> 2.6 !
> btw, i get the same failour, when i try to mount my sony u-20
> camera, which already worked on suse and woody, i think.
> how to go on searching ?
> tina
> kernel 2.6.7
> Module                  Size  Used by
> ide_cd                 49764  0 
> cdrom                  49660  1 ide_cd
> ide_scsi               20420  0 
> ide_disk               27072  4 
> sd_mod                 25152  0 
> scsi_mod              113376  2 ide_scsi,sd_mod
> unix                   31992  86 
> mount /cdrom                    
> mount: wrong fs type, bad option, bad superblock on /dev/hdc,
>        or too many mounted file systems
>        (could this be the IDE device where you in fact use
>        ide-scsi so that sr0 or sda or so is needed?)

You have loaded both, ide_cd and ide_scsi. Using 2.6 kernels doesn't
provide the ide_scsi yet. it is buggy. BTW you don't need that
module for burning CD's. Try cdrecord dev=/dev/hdd or something.
Have a look at
Documentation/post-halloween-2.6.txt ;-)

So, to solve your prob using 2.6:

modprobe -vr ide_scsi sd_mod scsi_mod
rm /dev/cdrom
ln -s /dev/hdc /dev/cdrom
mount /dev/hdc

/dev/cdrom points to /cdrom in yoour fstab:
mount /cdrom

else you have to fix /etc/fstab ;-)

Don't forget to remove the ide-scsi entries in grub/menu.lst
(lilo.conf) or/and remove it out of /etc/modules.



  Alles was viel bedacht wird ist bedenklich!;-)
         Friedrich Nietzsche

Attachment: signature.asc
Description: Digital signature

Reply to: