[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem, installing Debian on RS6000 P43-140

On Sun, 2004-09-05 at 13:05, nicolas wrote:
> On Sun, 2004-09-05 at 12:47, Juergen Braun wrote:
> > Hello,
> > 
> > I have a problem when trying to install Debian on an IBM RS6000 P43-140
> > 
> > I set up a dhcp/tftp Server (Debian stable, x86) and downloaded the file
> > 
> > http://ftp2.de.debian.org/debian/dists/sid/main/installer-powerpc/current/images/powerpc/netboot/vmlinuz-prep.initrd
> > 
> > saved this file as /tftpboot/boot.img and booted the P43 from net. The
> > box started downloading the boot image, but stopped after 2500 packets
> > and displays F77 on the LEDs:
> > 
> > RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000 RS/6000
> > RS/6000
> > 
> >      memory      keyboard     network      scsi      speaker       ok
> > BOOTP S = 1  R = 1
> > FILE: /tftpboot/boot.img
> > 
> > Load Addr=0x600000 Max File Size=0x10000000
> > Packet Count = 2500   
> > 
> > Any hints, what can be wrong?
> > 
> > jaybe
> Hi,
> the tftp transert can been aborted by an arp request (seen this on a FAS
> on the net). The workaround is to add a static entry for your 7043-140
> arp -s ip_7043-140 mac_7043-140
> I use this and I can netboot my 7043-140. If this works for you, can you
> tell me if the debian installer detects your scsi card and can install
> the right module ? Thanks

It looks that the scsi card isn't detected:
Linux/PPC load: load_ramdisk=1 console=ttyS0
Uncompressing Linux...done.
Now booting the kernel
Total memory = 512MB; using 1024kB for hash table (at c0300000)
Linux version 2.6.7-powerpc (jens@yorick) (gcc version 3.3.4 (Debian
PReP architecture
IBM planar ID: 000000d5
MPIC at 0xfddc0000 (0x3ddc0000), length 0x00040000 mapped to 0xeffc0000
On node 0 totalpages: 131072
  DMA zone: 131072 pages, LIFO batch:16
  Normal zone: 0 pages, LIFO batch:1
  HighMem zone: 0 pages, LIFO batch:1
Built 1 zonelists
Kernel command line: load_ramdisk=1 console=ttyS0
OpenPIC Version 1.0 (4 CPUs and 16 IRQ sources) at effc0000
PID hash table entries: 4096 (order 12: 32768 bytes)
time_init: decrementer frequency = 16.622468 MHz
Console: colour dummy device 80x25
Memory: 511424k available (1656k kernel code, 1088k data, 160k init, 0k
Calibrating delay loop... 330.75 BogoMIPS
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
checking if image is initramfs...it isn't (no cpio magic); looks like an
Freeing initrd memory: 4299k freed
NET: Registered protocol family 16
PCI: Probing PCI hardware
Setting PCI interrupts for a "IBM 43P-140 (Tiger1)"
PCI: Cannot allocate resource region 0 of device 0000:00:0b.0
PCI: Cannot allocate resource region 0 of device 0000:00:0c.0
PCI: Cannot allocate resource region 0 of device 0000:00:10.0
PCI: Cannot allocate resource region 0 of device 0000:00:12.0
Thermal assist unit not available
audit: initializing netlink socket (disabled)
audit(948037132.670:0): initialized
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
Generic RTC Driver v1.07
Macintosh non-volatile memory driver v1.1
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
pmac_zilog: 0.6 (Benjamin Herrenschmidt <benh@kernel.crashing.org>)
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
input: Macintosh mouse button emulation
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with
mice: PS/2 mouse device common for all mice
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 131072 bind 65536)
RAMDISK: Compressed image found at block 0
VFS: Mounted root (cramfs filesystem) readonly.
VFS: Cannot open root device "<NULL>" or unknown-block(8,3)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(8,3)
 <0>Rebooting in 180 seconds..

What additional parameter must be specified, that Linux is booting from
the initial ramdisk?
Linux/PPC load: load_ramdisk=1 console=ttyS0

> Nicolas

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: