[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Beige G3 console display

   I managed to get a new logic board for my beige G3, and with this
one the on-board ATI display actually works (under MacOS anyway). This
is lots better than the IMS Twin Turbo display.

   I can't get the thing to display a console while booting under
Linux, though. It works flawlessly under MacOS, but when I boot into
linux (using BootX), I get this on the display:

> Welcome to Linux, kernel 2.6.8-tinkerbell-3
> linked at        : 0xc0000000
> frame buffer at  : 0x82801000  (phys), 0xd801000  (log)
> klimit:          : 0xc03bb000
> MSR              : 0x00000072
> HID0             : 0x0210c0ac
> ICTC             : 0x00000000
> pmac_init(): exit
> id mach(): done
> MMU:enter
> MMU:hw init
> hash:enter
> hash:find piece
> hash:patch
> hash:done
> MMU:mapin
> MMU:setio
> MMU:exit
> setup_arch: enter
> setup_arch: bootmem
> arch: exit

   ... and there it hangs. If I wait long enough, it reboots, but
that's all. I can get it to boot properly by directing the console to
a serial port, and once it's booted I get VGA consoles (I can log in,
even run X), but I can't find a way to get the console to show up
while it's booting. I've tried every combination of
"video=atyfb:vmode:xx,cmode:yy" kernel command lines I can think of. I
actually read the BootX docs and added ",mclk:63" to that, but it
didn't help. I've tried it with "No video driver" selected and
unselected. I've tried it with "Force video settings" selected and
unselected. Still the same result.

   One possible clue is the output from dmesg:

> PCI: Probing PCI hardware
> PCI: Cannot allocate resource region 2 of device 0000:00:12.0
> PCI: Cannot allocate resource region 1 of device 0000:00:12.0
> Registering pmac pic with sysfs...
> SCSI subsystem initialized
> MacOS display is /pci/ATY,mach64_3DUPro

   Are the "Cannot allocate resource..." lines significant?

   Finally, here's the relevant output of `lspci -bvv`:

> 0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 5c) (prog-if 00 [VGA])
> 	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B-
> 	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
> 	Latency: 32 (2000ns min), Cache Line Size: 0x08 (32 bytes)
> 	Interrupt: pin A routed to IRQ 22
> 	Region 0: Memory at 82000000 (32-bit, non-prefetchable)
> 	Region 1: I/O ports at 1000 [disabled]
> 	Region 2: Memory at 80000000 (32-bit, non-prefetchable)

Ron Murray   (rjmx@rjmx.net)
GPG Public Key Fingerprint: F2C1 FC47 5EF7 0317 133C  D66B 8ADA A3C4 D86C 74DE

Reply to: