[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with IDE master/slave settings on Blue & White


I've got linux on a pb5300, G3-266, but the Blue & White gives
me problems.

Since I guess I have one of those first motherboards where the
second ide (Ultra ATA) doesn't work well, I try to install cdrom
as well as 40Gb disc on the first ide. The jumper settings that work best
for OS9 are (I can boot from cdrom AND hd)

Disk: CS (carrier select) +Master
cdrom: Slave

When trying to boot from linux cdrom, I get into Open Firmware 3.1.1
and it says "default catch". The system freezes. Here OS 9 works well,
no problem.

I have tried another setting, where the cdrom boots, but ... it doesn't
see the harddisk:

disk: CS + Master
cdrom: CS + Slave

I have the same problem with os X, install dies away, without saying anything.

I know there are memory issues, but I use one 64Mb pc100sdram that should be ok. With another chip, I have generated the message "drawrect: cannot find procedure" I guess at that moment there is something wrong with the ROM, where this kind
of procedures reside...

I should first resolve the ide settings.... and be able to boot from both cdrom and disk
on the same ide bus.  Or is that impossible with IDE?

Now, the things that might be interesting on my motherboard: (400mhz)
Apple Computer C(opyright) 1998

I don't see a word like "REV A" or "REV B"....

Inside the metal case, at the bottom-front I see:  805-2071B
The harddisk: (I guess this is OK...)
Maxtor 3.5 Series Diamond Max Plus 8
+12V  790mA
+5V    647mA

Reply to: