[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apple built-in Bluetooth not appearing in /dev

> List,
> 	I am running a 2.6.5-rc3-ben0 kernel with a sid installation on a 
> 1.25GHz 15" Aluminum PowerBook G4, which has built-in Bluetooth.  
> Although bluez-utils installed just fine and all of the messages on 
> startup indicate that hcid, rfcomm, l2cap, etc. are starting just fine, 
> I have no Bluetooth device available.  At first I thought it was 
> because I did not have an appropriate device driver compiled as a 
> kernel module, but I think I have eliminated that possibility (see 
> kernel config excerpt below).  When I run 'hcitool dev', nothing shows 
> up:

What debian branch are you running ? You need the hid2hci tool included
in the bluez-utils package in unstable.
It didn't work on my Powerbook G4 15" with linux-2.6.5 (caused a kernel
oops when switching from hid to hci) but it works great with a 2.6.7

I tested today and file transfer worked between my computer and a Dell.

Hope this helps,

Alain Perry

Reply to: