[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian boot CDs & G5

On Sat, Apr 24, 2004 at 05:02:51PM +1000, Benjamin Herrenschmidt wrote:
> Hi Sven !
> The current CDs won't boot a G5 with the -power4 option. The problem
> is that the kernel contains legacy drivers (8250 serial, etc...) that
> are fine for IBM POWER4 hardware, but will lockup a G5. You really need
> different kernel images for now.

Sorry for having been offline for all of this. I need to discuss this
with Jens and see what else this thread has brought.

One notice though. I would like to know the exact debian version that
was used for building those CDs (well, is it beta3, beta4, or a daily
built, and if a daily built, which date, or where the CDs self generated
or not ?).

That said, this situation is probably different from the one Jens spoke
of, since the debian-installer uses still the 2.4.25 kernel (altough i
don't know if -8 or -2 is used in your CD). I thought i had disabled the
serial port (and thus the serial console) on power4 for them though, not
sure if this fix is already included in your CDs though.

A proper fix would be for the serial driver to recognize that you are on
a mac, and not do the messy probing then.


Sven Luther

Reply to: