[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X problem on ibook G4

Hash: SHA1

On Mit, 12 Mai 2004, Pierre Evenou wrote:


> I'm sorry about this new thread, I saw there are already a lots of discutions on
> this subject but none of them solve my problem : I really can't make X working
> on my new iBook G4 !(PowerPC G4 1.2, Radeon M9+, debian sid)
> starting X give me a yellow flickering screen. Stopping X give me a flickering
> console (=> reboot)
Thats normal if your framebuffer is broken.

> I use debian kernel 2.6.5 patched with debian powerpc patches.
> I tried radeonfb compiled in the kernel and as a
> module(http://lists.debian.org/debian-powerpc/2004/01/msg00155.html) without
> success.
> I also tried xserver-xfree86-dri-trunk_powerpc_2004.02.28-2_powerpc,
> xlibmesa-gl1-dri-trunk_2004.02.28-2 and drm-trunk-module-src_2004.02.28-2_all
> with no result (black screen)

on my HP, http://www.reitmeir.org/ibook/ a placed the config files .., here is X working including DRI.
I use normal Debian/unstable, the only thing important for the kernel is the new radeon framebuffer module, it should compiled in static, and if you want to use the pbuttonsd, you have to enable the event interface (input section). My Kernel-Config is also on this page, so you can diff it against yours.

A pitfall is udev, if you use it, you have to create the /dev/fb0 by hand. A 
cd /dev
should do. I inserted the commands in an init.d script.

- --
mfG Florian Reitmeir
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: