[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Refresh rates for ibook G4 (Radeon 9200 (M9+))



Hello,
I try to get X (Michel Dänzers DRI-trunk, as suggested by ibook
install manuals) running on my iBook G4.

I (need to) boot with video=ofonly, otherwiese (e.g. video=radeonfb)
I get black running stripes over the text console.

Now I try to configure X. I got the drivers from Michel Dänzer, and
installed them. I am unsure, what I should enter for the sync rates:
        HorizSync       40-50
        VertRefresh     60
        Option          "DPMS"

After reading around, this seems to be ignored/unimportant? The device
section looks now:
Section "Device"
        Identifier      "Standardgrafikkarte"
        Driver          "radeon"
        Option          "UseFBDev"
        Option          "DRIReinit"
        BusID           "PCI:0:16:0"
EndSection

Starting X, I see stripes running over the screen, much like wrong
refresh (or wrong resolution) on a CRT.  When I kill X, I have nice
graphical effects (looks like an colourful implosion) and no text
console anymore.

In the server log I see:
(II) Setting vga for screen 0.
(II) RADEON(0): MMIO registers at 0x90000000
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules-dri-trunk/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
        compiled for 4.3.99.12, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.7
(II) RADEON(0): vgaHWGetIOBase: hwp->IOBase is 0x03b0, hwp->PIOOffset is 0x0000
(II) RADEON(0): PCI bus 0 card 16 func 0
(**) RADEON(0): Depth 16, (--) framebuffer bpp 16
(II) RADEON(0): Pixel depth = 16 bits stored in 2 bytes (16 bpp pixmaps)
(==) RADEON(0): Default visual is TrueColor
(**) RADEON(0): Option "DRIReinit"
(**) RADEON(0): Option "UseFBDev"
(==) RADEON(0): RGB weight 565
(II) RADEON(0): Using 6 bits per RGB (8 bit DAC)
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules-dri-trunk/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
        compiled for 4.3.99.12, module version = 0.0.2
        ABI class: XFree86 Video Driver, version 0.7
(WW) open /dev/fb2: No such device
(WW) open /dev/fb3: No such device
(WW) open /dev/fb4: No such device
(WW) open /dev/fb5: No such device
(WW) open /dev/fb6: No such device
(WW) open /dev/fb7: No such device
(EE) RADEON(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
        (you may have to look at the server log to see warnings)
(WW) RADEON(0): fbdevHWInit failed, not using framebuffer device
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules-dri-trunk/libint10.a
(II) RADEON(0): initializing int10
(II) RADEON(0): No legacy BIOS found -- trying PCI
(EE) RADEON(0): Cannot read V_BIOS (5)
(--) RADEON(0): Chipset: "ATI Radeon Mobility 9200 (M9+) 5C63 (AGP)" (ChipID = 0x5c63)
(--) RADEON(0): Linear framebuffer at 0x98000000
(--) RADEON(0): BIOS at 0x90020000
(--) RADEON(0): VideoRAM: 32768 kByte (64 bit DDR SDRAM)
(II) RADEON(0): AGP card detected

/dev/fb0 - /dev/fb7 do exist and are character devices. The permissions look
fine to me.

Suggestions or pointers to the right FAQ are much appreciated.

Thanks!

         Helge
-- 
Helge Kreutzmann, Dipl.-Phys.               Helge.Kreutzmann@itp.uni-hannover.de
  gpg signed mail preferred    gpg-key: finger kreutzm@zibal.itp.uni-hannover.de
    64bit GNU powered                  http://www.itp.uni-hannover.de/~kreutzm
       Help keep free software "libre": http://www.freepatents.org/

Attachment: pgpOHL0txdD5U.pgp
Description: PGP signature


Reply to: