[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem hcfsubmodem + binutils


My modem was working great with kernel 2.4.21-ben2,
but i had to upgrade to 2.6.4.

I try to recompile the modem drivers, but i get a
message telling to need recent version (because or
kernel), so i get
hcfusbmodem-1.01lnxt04032800ppcfull.tar.gz from
linuxant (previously i had
hcfusbmodem-0.99lnxtbeta03042703ppcfull.tar.gz )

Building modules for kernel 2.6.4, using source
/lib/modules/2.6.4/build. Please wait...

ERROR: Module build failed!
Please examine the log file
"/tmp/hcfusbconfig-buildlog.txt" to determine why.

#less /tmp/hcfusbconfig-buildlog.txt
rm -f *.o GPL/*.o *.ko GPL/*.ko *.mod.c GPL/*.mod.c
.*.cmd GPL/.*.cmd 
(cd /lib/modules/2.6.4/build && make
"SUBDIRS+=/usr/lib/hcfusbmodem/modules" modules)
make[1]: Entering directory `/usr/src/linux-2.6.4'
Makefile:558: target `/usr/lib/hcfusbmodem/modules'
given more than once in the same rule.
*** Warning: Overriding SUBDIRS on the command line
can cause
***          inconsistencies
make[2]: `arch/ppc/kernel/asm-offsets.s' is up to
*** 2.6 kernels no longer buildcorrectly with old
versions of binutils.
*** Please upgrade your binutils to 2.12.1 or newer
make[1]: *** [checkbin] Error 1
make[1]: Leaving directory `/usr/src/linux-2.6.4'
make: *** [all] Error 2

but i have binutils- installed (need to
compile 2.6 kernels)

Anyone have similar problem?
Any idea on who to make modem work?


Do you Yahoo!?
Yahoo! Small Business $15K Web Design Giveaway 

Reply to: