[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with 2.4.23-ben1

On Wed, Dec 17, 2003 at 11:42:37AM +0100, Jesus Climent wrote:
> Hi
> After reinstalling my laptop (ibook2, see www.hispalinux.es/~data/ibook) i am
> experiencing some problems.
> 1. the keyboard layout for spanish keyboards is completelly broken. I have
> modified a mac-usb-es.kmap.gz layout and will forward it to the console-data
> maintainer for inclusion. One remaining issue is the selection of the Alt and
> AltGr keys, since it might be of a different preference.

Solved. Setting the keyboard arch to pc (?!) solved most of my problems
(although I already had a working modification of the mac-usb-es map). The
remaining problem was the alt-gr key, which was solved setting the Switch-mode
action to that key.

> 2. the sound does not work. i will recompile with the original sound support
> as a module and try alsa (as suggested by Mr Bernat).

Sound working by recompiling 2.6.0-ben1 and using alsa. The default modprobe
does not work, but unloading and reloading the module finds the right card and
seems to work like a charm.

> 3. APM (or PMU) does not work anymore. with woody i got it working out of the
> box. now, the pmud daemon complains it cannot open the socket:
> syslog: bind socket
> syslog: daemon stopped (bind socket)

Problem solved setting lo to (somehow i missed that one, or the
installed if fscked)

> 4. the 2.4.23-ben1 kernel stops upon reboot after the ext3 checking and waits
> for some key press. 2.4.23-pre5-ben0 did not show the mentioned behaviour.

2.6.0-ben1 solved that problem too.

> 5. during my previous linux trip, i decided to set the ADB key codes and that
> forced me to use some varian of a xmodmap file. I had the kb working also
> under X with the same keyboard layout in X and in console.
> Now i seem unable to set the layout under X. I am using setxkb to select the
> right mapping. If i set the Meta_L key to mod1 it makes it work like an ALT
> key. It I set it to mod4, it does not work as AltGr. I tryed with mod3 and the
> same result. Any hins?


> 6. drm-trunk-module fails to load. after compilation, it shouts:
> unresolved symbol vmalloc_start

Hummm 2.6.0-ben1 seems to come with a quite recent dri module (1.9.0) although
I seem stupid enough to get more than 100FPS.

Looking better now ;)


Jesus Climent                                      info:www.pumuki.org
Unix SysAdm|Linux User #66350|Debian Developer|2.4.23|Helsinki Finland
GPG: 1024D/86946D69 BB64 2339 1CAA 7064 E429  7E18 66FC 1D7F 8694 6D69

You know what the real tragedy of this day is? I'm not even supposed to 
be here today!
		--Dante Hicks (Clerks)

Reply to: