[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Recompiling Kernel on G4 PowerMac Gigabit dual 450Mhz

I don't use make-kpkg or anything debian specific, so I might be way off. if
so I apologize.
are you sure you are running as root?


>>>-----Original Message-----
>>>From: Clive Menzies [mailto:clive@clivemenzies.co.uk]
>>>Sent: Wednesday, December 10, 2003 1:18 PM
>>>To: debian-powerpc@lists.debian.org
>>>Subject: Re: Recompiling Kernel on G4 PowerMac Gigabit dual 450Mhz
>>>On (10/09/03 21:49), Benjamin Herrenschmidt wrote:
>>>> On Wed, 2003-09-10 at 17:56, Clive Menzies wrote:
>>>> > Sometime ago I managed to recompile a 2.4.18 SMP kernel 
>>>and most things
>>>> > work OK but a few issues remain:
>>>> > 
>>>> > Poor sound quality
>>>> > Lack of video
>>>> > I've just added memory but only 512Mb are recognised
>>>> > Can't seem to read CD's or Zip files
>>>> > 
>>>> > I've recently tried to recompile to include HighMem and 
>>>rectify some of
>>>> > the above issues but the new kernels I've tried won't startx and
>>>> > recompiling again gives errors after I've made changes.  
>>>I've lost my
>>>> > original config file and so have to start again from 
>>>scratch.  I'm still
>>>> > using the original SMP kernel.
>>>> > 
>>>> > Are there any docs that give an idiots guide to config 
>>>selection for
>>>> > this machine?
>>>> Get my tree and make pmac_config
>>>Hi Ben
>>>I've repartitioned my system so that I've room to rsync your 
>>>kernel and
>>>I've gone through "make pmac_config" and "make xconfig" to tailor the
>>>kernel for my setup but in trying to compile the kernel, I've got an
>>>error that I can't resolve:
>>>:/usr/src/linux$ fakeroot make-kpkg clean
>>>Search pattern not terminated at -e line 1.
>>>/usr/bin/make -f /usr/share/kernel-package/rules real_stamp_clean
>>>Search pattern not terminated at -e line 1.
>>>make[1]: Entering directory `/usr/src/benh_kernel'
>>>test ! -f .config || cp -pf .config config.precious
>>>cp: cannot create regular file `config.precious': Permission denied
>>>make[1]: *** [real_stamp_clean] Error 1
>>>make[1]: Leaving directory `/usr/src/benh_kernel'
>>>make: *** [clean] Error 2
>>>No doubt this is my ignorance at work but I'd appreciate 
>>>some guidance.
>>>strategies for business
>>>To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
>>>with a subject of "unsubscribe". Trouble? Contact 

Reply to: