[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DRI module loading trouble on PPC, xfree86, debian/unstable

OK - thanks so far, this is what I found:

Using the r128 from 2.4.23-pre5-ben0 (I now disabled the Xfree 4.0.x
support) and 24/32 bpp I do not have enough memory, but the worse point
is, if I switch to 16bpp there is enough memory but the maschine
instantly crashes while staring up X in 16bpp mode, black screen and
it's 100% dead (no ping, no keystroke works, no X-mon) :-( Only a power
off helps...

The good point is using my old kernel 2.4.20-pre9-ben0 it now works and
I get up to "2450 frames in 5.0 seconds = 490.000 FPS" with glxgears
(G4/400) now! -- However, the fire-wire hotplugging (works once after
boot) is kind of bad with this kernel and I really like to use the newer

On Sun, 2003-11-09 at 13:44, Michel Dänzer wrote:
> On Sun, 2003-11-09 at 09:43, Percy Zahl wrote:
> > 
> > (WW) R128(0): Static buffer allocation failed -- need at least 10368 kB
> > video memory
> [...]
> > May be it did not works because I've only 8MB Videoram? There is a
> > warning "need at least 10368 kB".
> Indeed, you need to run at a lower virtual resolution and/or depth.
> Ah, you probably selected the DRM for XFree86 4.0.x in the kernel
> configuration; while that may work with newer r128 drivers, I'd
> recommend using the current DRM as well.


  .^.     my home (CO):  http://www.mines.edu/~pzahl
  /V\             (CH):  http://mypage.bluewin.ch/pz
 //G\\    Visit GXSM now! Unlimited and free SPM+ software:
/(XSM)\        ----->  http://gxsm.sf.net  <------

Reply to: