[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

IMS TT video issues

I have just spent most of the last couple of days installing Debian Woody on
a PowerMac 9600/300 and getting kernel 2.4.18 built and (mostly) working. I
have a couple of remaining issues that are plaguing me.

1) If I use a pre-built 2.4.18 kernel, or a normal home-built one, the
   monitor goes blank on boot-up. I have tried just about all of the
   combinations of video=ofonly, video=fbdev and video=imsttfb without
   success. The 2.2 installation kernel that I was using to install does
   work, and looking at /var/log/dmesg, the difference is that 2.2 thinks the
   video board uses the TVP RAMDAC, whereas 2.4 thinks it uses the IBM

   If I comment out the line that sets "pdev->ramdac = IBM" in
   drivers/video/imsttfb.c, and let it fall through to the TVP case, I get
   monitor output using video=imsttfb, except that the cursor is invisible or

   The /proc/devices-tree entry indicates that I have an imstt128mb8A (IBM
   RAMDAC), and setting the output-device in OpenFirmware to
   /bandit@F4000000/IMS,tt128mb8A gives me boot-time output. lspci -v
   indicates the card is an IMS 9129 Twin Turbo 128 Rev 01 (PCI device ID is
   0x9128), and claims it has 16MB memory (rather than the 4 or 8Mb suggested
   by the driver). I haven't pulled the video card out yet to check out what
   chips are on board.

   What on earth is happening? I'm not going to be running X on this machine,
   so I only care about console output, but I don't want to accidentally blow
   the video card up. I would like a cursor too, it makes it much easier to
   see where you're typing.

2) Having got video on bootup, how can I get rid of the d**m penguin on the
   bootup screen? It really makes scrolling r-e-a-l-l-y slow.

3) Can I force an extra SCSI controller to be lower in the search order than
   the on-board controllers? If so, how? The next step will be to move data
   from my old machine over, however I need to put a PCI SCSI card in the
   PowerMac with the drives from the old machine attached, the data is on U2W
   drives and the internal controller doesn't do U2W. When I tried putting
   the card in the PowerMac the kernel scanned it first, changing the root
   filesystem drive from /dev/sda to /dev/sdb. It wasn't a success, needless
   to say.

A final comment about the install process: it would have been much easier if
the Debian on PowerPC installation Manual had mentioned "nvsetenv" somewhere.
I wasted a lot of time rebooting and trying to type blind at prompts because
OpenFirmware input and output was connected to the serial port. This
installation was a complete replacement for MacOS, by the time I found out I
needed to change the OpenFirmware settings it was too late to run bootvars.
The 2.2 installation kernel was booting however, I could have used nvsetenv
much earlier to reset the output and input device.


Reply to: