[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cdrecord doesn't recognize cdburner

On Sat, 6 Sep 2003, Mannequin* wrote:

> I've got a PB G3 Firewire, with kernel 2.4.21-powerpc, and a Lacie CD
> burner attached to my firewire port.
> Here's what dmesg says when I plug the drive in:
> ieee1394: Node 00:1023 changed to 01:1023
> ieee1394: Node 01:1023 changed to 00:1023
> ieee1394: Node 00:1023 has non-standard ROM format (0 quads), cannot
> parse ieee1394: Node 00:1023 changed to 01:1023
> ieee1394: Node 01:1023 changed to 00:1023
> ieee1394: sbp2: Node 01:1023: Using 36byte inquiry workaround
> ieee1394: sbp2: Logged into SBP-2 device
> ieee1394: sbp2: Node[01:1023]: Max speed [S400] - Max payload [2048]
> ieee1394: NodeMgr: hotplug policy returned -2
> ieee1394: Device added: Node[01:1023]  GUID[00d04b2111070b30]  [LaCie
> Group SA  ]
> To double check everything, I do a:
> sudo rmmod sbp2
> sudo modprobe sbp2
> sudo cdrecord -scanbus
> The problem I'm having is that cdrecord won't recognize it:
> Cdrecord 2.01a16 (powerpc-unknown-linux-gnu) Copyright (C) 1995-2003
> Jörg Schilling
> cdrecord.mmap: No such file or directory. Cannot open '/dev/pg*'. Cannot
> open SCSI driver.
> cdrecord.mmap: For possible targets try 'cdrecord -scanbus'. Make sure
> you are root.
> cdrecord.mmap: For possible transport specifiers try 'cdrecord
> dev=help'.
> cdrecord.mmap: Also make sure that you have loaded the sg driver and the
> driver for
> cdrecord.mmap: SCSI hardware, eg. ide-scsi if you run IDE/ATAPI drives
> over
> cdrecord.mmap: ide-scsi emulation.
> Read/usr/share/doc/cdrecord/README.ATAPI.setup!
> This all worked fine until I upgraded from 2.4.18-powerpc to
> 2.4.21-powerpc. Can anyone direct me as to how I can get this working
> again, so I can make backups?

There was a change int he 1394/firewire subsystem somewhere after 2.4.18.
The solution is to get the debian package with rescan-scsi-bus.sh and
run that script.  Running 'modprobe' or 'insmod' on the individual 1394
modules will NOT work.  I tried all of this, and nothing worked till I
ran this script, then accessed my firewire devices (a hard drive in my

This should be in the debian-powerpc archives from earlier this year.


To get my real e-mail address, replace "4" with "for" in the above address


"I can't understand people who hate other people based on things like race,
 religion, or sexual orientation.  When you really do get to know a person,
 aren't there so many more worthwhile reasons for despising them ?"

                                        Dennis Miller

Reply to: