[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

resetting journal on ext3 system ...

Hi Folks,

I came across some rather peculiar happening with Woody on my 8500 (it's
a stock system, except for a 2.4.20 kernel).  When I run a df as root on
the system, I get:

kaiso:/# df -k

Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda7               495844    455382     14862  97% /
/dev/sda8              1032088    741300    238360  76% /usr
/dev/sda9              1519116   1056316    385632  74% /misc_space
/dev/sdb               4392296   1487760   2681412  36% /home

The root partition is the things worrying me.  When I check all of the
sub-directories within root though:

kaiso:/# du -xsm /

76      /

I only get about 76 MB of files.  When I do this in / , however:

kaiso:/# du -s .

4052342 .

The only thing I can think of is my journal file has become rather large.
Is that the case, and if so - is there a way to reset the journal on my
filesystems, so I can choose more manageable sizes ??  I tried running
tune2fs -J size=64, but I was told there was already a journal on the

If I'm wrong about the journal becoming too large, what else could this
be ?


P.S. The above e-mail address is bogus.  To get the correct one, replace
the "4" with "for"

Reply to: