[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fwd: Re: Booting the Debian installation CD on Powerbook G4 12"

On Thu, Feb 27, 2003 at 12:22:34AM +0000, David Mery wrote:
> Orion,
>  I posted the message below to the very interesting thread you
> started on installing Debian on a G4 12". However I posted it via
> google and though it has appeared on the ng via google, it hasn't
> showed up on debian.org.


> Following Orion's very useful recommendations, I eventually managed to
> install Woody on my G4 12". However the last step of the install to
> make the system bootable failed. I've tried to boot it by booting from
> the Open Firmware to a yaboot on Mac OS X with a yaboot.conf pointing
> to the Debian partition... and that fails as well. Debian appears to
> start to boot but then complains that it doesn't have a root. I've
> tried adding a root= statement in yaboot.conf with all the possible
> values I could think of and still no success.

You don't still have the initrd (and initrd-size and
append="disksize=2.88") argument, do you?  That would probably sink
you; comment out that line.  If you have removed that and it still
doesn't work, what were the "possible values" you could think of?  You
probably have at least

hdc1 = Apple_partition_map
hdc2 = Apple_HFS -- your OS X root
hdcX = Apple_Bootstrap -- the 800kB NewWorld bootblock (not needed if
			  booting from OS X, but certainly a good idea)
hdcY = Apple_UNIX_SVR2 -- the root partition
hdcZA-W = swap and homes and stuff

If you're booting from the OS X yaboot, you would boot from OF with
boot hd:2,yaboot
and a yaboot.conf like:


If you're booting from your GNU/Linux root, you would boot from OF with
boot hd:X,yaboot
and a yaboot.conf like:

#        append="hda=ide-scsi"   # optional, for your combo/superdrive


> I'm starting to wonder whether the install process didn't use (from
> the Woody non-US CD) an pre 1.3.9 yaboot and/or a non modified kernel,
> either of being a potential problem. I'm a bit surprised though that
> it seems to start the boot process (so seems to be able to access the
> Debian partition). Any idea on how to solve that? If it requires a
> different image, is there a working one available or some instructions
> (for a novice) as to how to create one myself?

My Woody non-US certainly used a pre-1.3.9 yaboot, but that didn't
stop me.  The "make system bootable" failed for me, too; only today
did I manage to boot directly into Debian, and I'm not sure what I did
differently (I ran ybin and then mkofboot, when I usually just run
mkofboot, but I didn't think that would make a difference).  You
shouldn't need a different kernel image from the one you used to

I might recommend booting again with the CD and checking out which is
your root partition, and making sure your system looks workable.  I'm
not sure how "novice" you are, but you should be able to boot with the
boot.img initrd and get a shell, and do mac-fdisk -l /dev/hdc to see
your partition map.

Hope this helps and is not too disorganized.


Reply to: