[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with Dual boot MacOSX/Woody - Yaboot on G4 Gigabit

On Friday, February 7, 2003, at 08:37  pm, Derrik Pates wrote:

On Fri, Feb 07, 2003 at 07:42:21PM +0000, Clive Menzies wrote:
Doesn't seem to help. I checked the man yaboot.conf page; it refers to
HFS+ but my set-up is totally HFS.

No, if you're running OS X off of it, it's HFS+. OS X doesn't support
HFS as a boot volume. Did you try putting the option in, rerunning
'ybin', and booting?

Yep.  I tried it again just now but to no avail ;-(

So maybe I shouldn't be trying to boot OSX specifically but generic
macos?  I tried that but it didn't make any difference.

No, that assumes classic MacOS, so it searches the volume for the 'Mac
OS ROM' file that classic MacOS starts from.
Yes - I can see that ;-)

I guess it's not crucial because I can boot both systems.  But what is
interesting is that I boot Linux using "boot hd:2,yaboot" in OF and it
works fine.  Which suggests that I need to modify yaboot.conf to boot
OSX.  Will yaboot only boot OSX using the two stage boot process?

Yes, because the Forth bootscript that ybin generates and blesses is
what puts up the multiboot menu - yaboot itself just loads Linux

My problem is that the Forth bootscript generated by ybin seems to expect both a MacOSX_bootstrap partition (which it seems to find) AND MacOSX_second_stage partition which it can't find. I've got 6 Apple Driver partitions, one Apple patches partition and one HFS partition containing MacOSX and OS9.2 with the bootstrap included (I presume). Is there a way of forcing the extraction of the multiboot menu?

Thanks for persevering


Reply to: