[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with Dual boot MacOSX/Woody - Yaboot on G4 Gigabit

On Friday, February 7, 2003, at 03:05  am, dpates@dsdk12.net wrote:

Quoting Clive Menzies <clive@clivemenzies.co.uk>:

I've run ybin after changes

But straight booting sticks on something like "Starting bootstrap
second stage ...." and just stops.  If I reboot into OF and type "boot

hd:2,yaboot", Linux boots fine (I used the sample yaboot.conf from 6.5

Kernel Image settings).

I don't really want to repartition (too much important stuff on MacOSX

to lose).  Am I missing something obvious?

Have you tried adding the 'brokenosx' option to your yaboot.conf? It was necessary last I used OS X (10.1.x) on a Mac with Linux and OS X installed, and according to the yaboot.conf manpage, is still needed for any OS X install on an
HFS+ partition. Give it a try, and see if it helps you.

Thanks Derek,

Doesn't seem to help. I checked the man yaboot.conf page; it refers to HFS+ but my set-up is totally HFS.

The mac-link document refers to MacOSX_Bootstrap and MacOSX_Second_stage partitions, neither of which I have on my system because OSX was installed on top of OS9.2. Yaboot seems to hang looking for ...second stage bootstrap...

So maybe I shouldn't be trying to boot OSX specifically but generic macos? I tried that but it didn't make any difference.

I guess it's not crucial because I can boot both systems. But what is interesting is that I boot Linux using "boot hd:2,yaboot" in OF and it works fine. Which suggests that I need to modify yaboot.conf to boot OSX. Will yaboot only boot OSX using the two stage boot process?

I'm still struggling with the concepts of all this and may be way off track ;-)



Derrik Pates

To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: