[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Umax Pulsar with Woody freshly installed: X freezes

On Sam, 2003-01-04 at 23:23, Christian Walther wrote: 
> The installation is fine, the system works fine when in console mode. 
> But when I try to launch X the Server freezes after a few seconds. A normal 
> "startx"-sequence never comes to an end, and just starting the X-Server 
> itself - without any WM or something else - is no problem. Launching a 
> XClient from the Command Line then freezes the screen, just the mouse cursor 
> can be moved around. Eterm for example is capable of creating a menu and a 
> backdrop, but no shell process is launched.
> From this point on the CPU usage increases, reaching levels of more than 1. 
> When I log via ssh I can kill -9 the X-Server, but the screen won't come back.
> When running the X-Server "stand alone" and switching to console, and finally 
> back, breaks everything, too. The server freezes, the keyboard won't respond. 
> I need to reboot.
> My setup is:
> Umax Pulsar with (currently) one 604e/233
> 592MB RAM
> Matrox Millenium II w/ 4MB in Slot B (PCI:0:14:0)
> Kernel: Default Debian 3.0 installation kernel (2.2.20) or compiled 2.2.22 
> Boot-Options (BootX): video=matrox:vesa:0x193 (1152x864@32Bits)
> I tried using the Kernels Framebuffer as well as letting X take control 
> over the screen itself. I reduced the resolution of the Framebuffer, 
> and the default resolution for X. I tried changing the  kernel from my 
> own one to the standard installation kernel (and back).

Sounds like a problem with some hardware acceleration, which you can
verify with Option "NoAccel". If that works, you can hope that only
certain acceleration functions are affected, and play with the various
"XaaNo..." options documented in the XF86Config-4 manpage.

> Disabling DRI (because I read in the archive that there might be a 
> problem in the standard package) by uncommenting the Load "DRI" line in 
> the modules section didn't change anything.

I doubt that mga DRI works on PPC with my dri-trunk packages, much less
the official Debian packages.

Earthling Michel Dänzer (MrCooper)/ Debian GNU/Linux (powerpc) developer
XFree86 and DRI project member   /  CS student, Free Software enthusiast

Reply to: