[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Woody on RS/6000 - still no progress

Hi all,

I'm still trying to install woody on an IBM RS/6000 7025 F50.

I'm booting off the net via BOOTP/TFTP.  The console is on a serial port.

I still have two problems:

1.  The furthest I've got is a very slow - unusable - Debian installer;
the console takes half an hour to redraw a screen.  As soon as the boot

Serial console detected.  Disabling virtual terminals

appears, the console slows to a crawl.

2.  Even so, the SCSI host adapter doesn't start properly.  I've tried all
varieties of the SYM58XX driver, with m-mapped IO and without.  The only
difference is that wth m-mapped IO I do get to the slow Debian installer,
though with a non-functional SCSI system, and with normal IO I never get
to the installer at all; booting stops at the SCSI initialisation with
messages like:

SCSI subsystem driver Revision: 1.00
PCI: Enabling device 00:0c.0 (0140 -> 0143)
sym.0.12.0: setting PCI_COMMAND_MASTER...
sym.0.12.0: setting PCI_COMMAND_INVALIDATE.
PCI: Enabling device 80:0b.0 (0140 -> 0143)
sym.128.11.0: setting PCI_COMMAND_MASTER...
sym.128.11.0: setting PCI_COMMAND_INVALIDATE.
sym0: <825a> rev 0x13 on pci bus 0 device 12 function 0 irq 17
sym0: No NVRAM, ID 7, Fast-10, SE, parity checking
sym0: SCSI BUS has been reset.
sym1: <825a> rev 0x13 on pci bus 128 device 11 function 0 irq 26
sym1: No NVRAM, ID 7, Fast-10, SE, parity checking
sym1: SCSI BUS has been reset.
scsi0 : sym-2.1.16a
scsi1 : sym-2.1.16a
sym0:0:0: ABORT operation started.
sym0:0:0: ABORT operation timed-out.
sym0:0:0: DEVICE RESET operation started.
sym0:0:0: DEVICE RESET operation timed-out.
sym0:0:0: BUS RESET operation started.
sym0:0:0: BUS RESET operation timed-out.
sym0:0:0: HOST RESET operation started.
sym0: SCSI BUS has been reset.

This behaviour seems to be consistent no matter whether I apply the
powerpc patches or not, and whether I use 2.4.15, 2.4.18 or 2.4.19
sources (2.4.19 only without the patch; I couldn't find a powerpc patch
for 2.4.19).

I am at a complete loss, especially since an existing YellowDog Champion
Server 1.2 with kernel 2.2.17 is installed on one of the disks and boots
flawlessly, and on the graphical console too.

Any ideas?

Best regards,

|   George Karaolides                      Planitis Communications Ltd.,  |
|   tel:   +357 22 45 65 00              Office 102, 11 Florinis Street,  |
|   web:   www.planitis.net                             Nicosia CY 1065,  |
|   email: george.karaolides@planitis.net           Republic  of Cyprus.  |

Reply to: