[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#155095: libmm11 1.1.3-7 broken on PowerPC

Great :-)

After running a few more tests...

It appears that this only happens if the first argument to mm_create() is
0, which should tell it to allocate the largest possible block-o-mem,
according to the docs.  I added a printf to make sure that the size it
wanted to create was reasonable and below shmmax (which it was).  Now,
here's the odd part, I rebuilt the libmm12 package itself and installed it
(ZERO changes) and it suddenly worked.  Also, rebuilding libmm11 (again,
without changes) on my machine seemed to fix things as well.

The only thing that I can think of is that there is or was a toolchain bug
on the powerpc that built the last libmm debs (and the libmm12 deb).  If
you built them, what versions of the toolchain packages are you
running?  If it's the buildd's, then they should be checked out as well.


On Thu, 1 Aug 2002, Mark Brown wrote:

> On Thu, Aug 01, 2002 at 11:43:23AM -0400, Christopher C. Chimelis wrote:
> > Good idea.  MMFILE is probably the safest, although I'm still puzzled as
> > to why IPCSHM seems to be so flaky.
> > It proved one thing: that compiling against libmm12 didn't make a
> > difference :-P  I still get the same problems with the IPCSHM-configured
> > libmm12.
> I've got an MMFILE-forced package ready for upload - should be in
> incoming tomorrow.
> -- 
> "You grabbed my hand and we fell into it, like a daydream - or a fever."

Reply to: