[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't start installation via yaboot at OpenFirmware prompt

At OpenFirmware prompt, I'm typing "boot hd:14,yaboot" and getting
"can't OPEN: 14:hd,yaboot   ok".

I've also tried "boot HD:14,yaboot" and "boot HD:[2-14],yaboot" and
"boot hd:[2-14],yaboot" and "boot hd:" and "boot: HD" and "boot: hd,13"
etc etc etc.

This is on a Blue&White G3, 128MB RAM, 6GB drive.

I've pretty comfortable with Debian on i386, but real green (novice) on
Debian for Mac.

When I began this project, the machine had OS 9.2.1 on it, and I started
by following the installation instructions at debian.org for PowerPC
(http://www.debian.org/releases/stable/powerpc/install, particularly at
section, which is where I got the "debian-imac" folder).

I misread the "using-pdisk.txt" and did an "i" to wipe out the partition
table completely, and then created a partition scheme that I thought
would provide me with Linux and Mac, but when I booted off the OS 9 CD
the hard drive was no longer visible. It took a while (and a re-read of
"using-pdisk.txt") to figure out I needed to reinstall OS 9 to get the
disk drivers back in the partition table. So I started over with
partitioning, this time leaving the disk drivers alone.

I've tried several variants of my partitioning scheme, but nothing seems
to work. Here's my current scheme as reported by pdisk:

This app uses the SIOUX console library
Choose 'Quit' from the file menu to quit.

Use fake disk names (/dev/scsi<bus>.<id>; i.e. /dev/scsi0.1,
/dev/scsi1.3, etc.).

Top level command (? for help): l
Name of device: /dev/ata0.0

Partition map (with 512 byte blocks) on '/dev/ata0.0' (/dev/hda)
 #:                type name              length   base     ( size )
 1: Apple_partition_map Apple                 63 @ 1
 2:     Apple_Bootstrap boot                1600 @ 12654848
 3:    Apple_Driver_ATA*Macintosh             54 @ 64
 4:    Apple_Driver_ATA*Macintosh             74 @ 118
 5:  Apple_Driver_IOKit Macintosh            512 @ 192
 6:       Apple_Patches Patch Partition      512 @ 704
 7:     Apple_UNIX_SVR2 swap              524288 @ 1216     (256.0M)
 8:     Apple_UNIX_SVR2 /                 153600 @ 525504   ( 75.0M)
 9:     Apple_UNIX_SVR2 /tmp               51200 @ 679104   ( 25.0M)
10:     Apple_UNIX_SVR2 /usr             3276800 @ 730304   (  1.6G)
11:     Apple_UNIX_SVR2 /var              512000 @ 4007104  (250.0M)
12:     Apple_UNIX_SVR2 /home            1024000 @ 4519104  (500.0M)
13:           Apple_HFS "MacOS"          6963200 @ 5543104  (  3.3G)
14:           Apple_HFS "MacShared"       148544 @ 12506304 ( 72.5M)

Device block size=512, Number of Blocks=12656448 (6.0G)
DeviceType=0x0, DeviceId=0x0
1:  21 @ 64, type=0x701
2:  34 @ 118, type=0xf8ff

Top level command (? for help):

After my first mistake of wiping out the partition table and then having
to reinstall OS 9, I created a partition table similar to the one above,
but I had the Apple_Bootstrap partition between 6 and 7 (so it was 6). I
later moved that (using the "r" command) to the second partition as per
another HOWTO I found. I also planned to have both OS 9 and OS/X, and I
understood that OS/X needed Apple_HFS+ (or UFS, which has been
recommended against by two Mac-head friends and by what I've read
today), so I created the "MacOS" partition as "Apple_HFS+", and created
the "MacShared" partition as "Apple_HFS" (I couldn't find any
documentation as to what the correct type was for HFS+, so I just
guessed that it was "Apple_HFS+".

When I then booted off the OS 9 CD, it wanted to initialize one of the
Mac partitions (I don't remember now the exact sequence), and it seems
like one of the drives (the HFS+ I think) didn't even show up, so I did
a bit of tweaking and finally got both drives to show up on the desktop.
I then installed OS 9, and put the "debian-imac" folder on the
"MacShared" folder, and put the four special files (yaboot, yaboot.conf,
linux, and root.bin) onto the root of "MacShared" also.

I then rebooted into OpenFirmware, and started having problems.

Throughout the day, I've gone back and installed OS/X as well, and some
time after that noticed that it had converted the "MacShared" drive into
"MacOS Extended", so I re-initialized that drive as "MacOS Standard".

Still, it seems odd to me that the "Get Info" on the "MacOS" drive shows
"Mac OS Extended" and the "MacShared" drive shows "Mac OS Standard", yet
pdisk shows both partitions as "Apple_HFS".

Hopefully that's enough information for someone to point me to a fix.



To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: