[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /dev/dsp

# lsmod
Module                  Size  Used by    Not tainted
rtc                     1792   0  (autoclean)

After seeing your previous post, I'm not sure I *want* alsa installed. I'd rather not be the one to find out whether it does the same thing on a G4. :)

Thanks for any help you can offer though.


Laurent wrote:

What's the lsmod output looks like? Do you have ALSA installed? I've been going to the whole mambo of mucking around with sound last night (see previous post), so maybe I can help.


Thomas Peri wrote:

I've just installed woody new-powermac on my G4, and most things are working nicely. I'm stuck on getting sound to work, though.

Upon login to KDE, I was told that permission had been denied for /dev/dsp. I happily ignored it for the time being, and installed fluxbox, since I don't really care for KDE or Gnome. After I'd been using it for a while, it occurred to me that sound wasn't working here either. So I tried running xmms, and got the following error immediately:

libmikmod.so.2: cannot open shared object file: No such file or directory

I don't know whether that's related. But when I tried to play something, I got a message similar to the one KDE had given:

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Permission denied

...so I checked permissions:

crw-rw----    1 root     audio     14,   3 Mar 14 02:11 /dev/dsp

...added myself to group audio, tried playing in xmms again, and got the same error. So just for fun, I changed the permissions to world-read-writable:

crw-rw-rw-    1 root     audio     14,   3 Mar 14 02:11 /dev/dsp

...and tried playing in xmms again.  This time I got a new error:

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): No such device

I don't know where to go from here.  Can someone help please?


Thomas Peri

To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: