[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Endless Problems with XF86Config, what am I doing wrong?


Similar to the thread below, I am trying to move beyond 640 x 480. In the spirit if Linux do-it-yourself, I spent a good 7-8 hours trying permutations of XF86Config and googling around the net trying various combinations "Linux", "no modes available", "XF86Config", "device" "7600/120", etc., in the hopes of finding the simple trick that would let me display 832x624 and thousands of colors.

I have an absolutely plain vanilla 7600/120. The only thing in it not original equipment is the extra hard drive for Linux. It is hooked to an Apple Multiple Scan 17 Display.

I commented out all of the Modeline's in XF86Config accept for the last one, which appears to be targeted at the apple display. It reads:

Mode "832x624"
        Dotclock 57.598
        HTimings 832 880 944 1152
        Vtimings 624 625 628 667
        Flags "-Hsync"  "-Vsync"
End Mode

This mode is NOT discarded during startx, i.e., it meets the monitor's criteria.

In the Screen section I called out the proper monitor name, and the "Linux Frame Buffer Device" as the device, "16" as the default colors. I commented out all but one Subsection. The one subsection calls out for Mode = "832x624"

I tried BootX with "no video driver" forced, and then (from the LinuxPPC FAQomatic) tried the kernel arguments:

video=controlfb:vmode:13,cmode:16  3

vmode=13 is for 832x624, 75 Hz

Still no joy.

What am I doing wrong? Anyone else have a plain vanilla 7600/xxx? How do I get X to work? Very frustrating...

At 11:43 AM 11/12/01 +0100, you wrote:
Matt Brubeck wrote:
> On Thu, 8 Nov 2001, Christian Zapf wrote:
> > The only thing I could not yet figure out is how to change the screen
> > resolution on my AppleVision 17" monitor. My XF86Config files looks
> > OK, but fbset seems to know only about "640x480-66". If I can't fix
> > that on my own, I guess I'll drop a note here to get some help.
> I'll try to help even though you haven't asked yet.  :)
> If you are booting with "no video driver" or "video=ofonly", then you
> won't be able to change resolution.  If you have one of these enabled in
> your bootloader, disable it.  I believe your machine should be using the
> atyfb driver.

Thanks Matt! I checked what kernel arguments I could add to set the
right resolution. On my PM 8500 I need "video=controlfb", I also added
vmode:18"" which is supported by my display. However, I cannot change
resolutions on the fly. I'm wondering if that would work by simply
dropping the "vmode:18" part... I'll have to try that later on.


Mike Yukish
Head, Manufacturing Product & Process Design Department
Applied Research Lab/Penn State University
(814) 863-7143

Reply to: