[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Video Argument for BootX

On Fri, Apr 13, 2001 at 10:18:36PM -0400, michael sean edwards wrote:
> I am having some trouble with X Windows and my video card. Its a standard
> ATI card that came with my 9500. Anyway what is the argument I need to tell
> the system what my resolution and bit depth is? Thanks to anyone who can
> help. 
> I tried turning off the video driver in BootX but X windows died on me
> anyway. With the driver working I get a mangled screen and a hang.
> Sheesh, never the same thing twice.

 You shouldn't need to turn off the vid driver.  (That sets video=ofonly,
which makes things totally unaccelerated :(. ).

 You can configure X by editting /etc/X11/XF86Config, or XF86Config-4,
depending on whether you're using X 4.0 or not.  (If you're running potato,
you probably have 3.3.6, not 4.0.2).  I've got a 9500-based SMP system with
a Mach64 video card.  The machine locks if I use the ati driver in X.  (I can
ping it for a while, but it locks up even more completely after that, IIRC.)
I'm using X 4.0.  I can use the framebuffer X server, though.
 To set the color depth, you use defaultdepth in XF86Config-4.  You use
defaultcolordepth in XF86Config (for X < 4.).

 I used fbset to try video modes, and when I found ones that worked, I used
fbset -x to get X syntax for them.  I don't know why it puts 
"XFree86 doesn't support accel", but I think that's because the fb mode has
the "accel" flag set, and X can't use that.

 If you're using X 3.3.6, then you'll have to adapt this config to yours.
My XF86Config-4 has (non-ATI-on-PMac-related sections removed):

# **********************************************************************
# Monitor section
# **********************************************************************

Section "Monitor"
    Identifier  "Compaq clunker"

    HorizSync   30-69  # can't find specs for this monitor?
    VertRefresh 50-70

    Mode "640x480-67"    # copied from output of fbset -x
        # D: 30.171 MHz, H: 34.921 kHz, V: 66.515 Hz
	DotClock 30.172
	HTimings 640 720 784 864
	VTimings 480 483 486 525
	Flags    "-HSync" "-VSync"    # Warning: XFree86 doesn't support accel

    Mode "1024x768-70"   # copied from output of fbset -x
    	 # D: 74.660 MHz, H: 56.220 kHz, V: 69.752 Hz
         DotClock 74.661
	 HTimings 1024 1048 1184 1328
	 VTimings 768 771 777 806
	 Flags    "-HSync" "-VSync"    # Warning: XFree86 doesn't support accel

 # other VESA standard modes are built into X 4.0

Section "Device"
    Identifier  "mach64"
    Driver      "ati"
    BusID	"PCI:0:13:0"
    option "usefbdev"

Section "Device"
    Identifier  "fb"
    Driver      "fbdev"

# **********************************************************************
# Screen sections
# **********************************************************************

Section "Screen"
    Identifier  "Screen 1"
#    Device      "mach64"  #m64 locks the console. can still ping...
    Device      "fb"
    Monitor     "Compaq clunker"
    DefaultDepth 24
    Subsection "Display"
        Depth       24
 	Modes        "640x480-67" "1024x768-70"
        ViewPort    0 0

 The config above does actually work.  I can run X, and it gives output like

XFree86 Version 4.0.2 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 18 December 2000
	If the server is older than 6-12 months, or if your card is
	newer than the above date, look for a newer version before
	reporting problems.  (See http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.18pre21 ppc [ELF] 
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Apr 14 21:53:12 2001
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (??) unknown.
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "Compaq clunker"
(**) |   |-->Device "fb"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) XKB: rules: "xfree86"
(**) XKB: model: "macintosh"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

... (scanpci.a)
(--) PCI: (0:13:0) ATI Mach64 GX rev 3, Mem @ 0x81000000/24
(II) FBDev: driver for framebuffer: fbdev, afb
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
	compiled for 4.0.2, module version = 0.0.2
(II) FBDev(0): using default device
(II) Running in FRAMEBUFFER Mode
(**) FBDev(0): Depth 24, (--) framebuffer bpp 32
(==) FBDev(0): RGB weight 888
(==) FBDev(0): Default visual is TrueColor
(==) FBDev(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDev(0): Hardware: ATY Mach64 (vidmem: 4096k)
(==) FBDev(0): Option ShadowFB is on
(II) FBDev(0): Checking Modes against framebuffer device...
(II) FBDev(0): 	mode "640x480-67" ok
(II) FBDev(0): 	mode "1024x768-70" ok
(II) FBDev(0): Checking Modes against monitor...
(--) FBDev(0): Virtual size is 1024x768 (pitch 1024)
(**) FBDev(0): Mode "640x480-67": 30.2 MHz (scaled from 0.0 MHz), 34.9 kHz, 66.5 Hz
(**) FBDev(0): Mode "1024x768-70": 74.7 MHz (scaled from 0.0 MHz), 56.2 kHz, 69.8 Hz
(++) FBDev(0): DPI set to (100, 100)
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
	compiled for 4.0.2, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libshadowfb.a
(II) Module shadowfb: vendor="The XFree86 Project"
	compiled for 4.0.2, module version = 1.0.0
(--) Depth 24 pixmap format is 32 bpp
(==) FBDev(0): Backing store disabled
(**) Mouse1: Protocol: "PS/2"

 Video is pretty slow with that setup.  Maybe it's just uwm that makes
things feel _really_ slow, since wm2 feels a lot faster.  I'll give
something else a try.  fvwm2 seems to segfault...

 Anybody know if the ATI X4.0.2 driver is supposed to work?

#define X(x,y) x##y
Peter Cordes ;  e-mail: X(peter@llama.nslug. , ns.ca)

"The gods confound the man who first found out how to distinguish the hours!
 Confound him, too, who in this place set up a sundial, to cut and hack
 my day so wretchedly into small pieces!" -- Plautus, 200 BCE

Reply to: